Make WordPress Core

Opened 3 years ago

Closed 16 months ago

#47416 closed defect (bug) (invalid)

Site health - Rest API error - cURL error 28

Reported by: nirvak Owned by:
Milestone: Priority: normal
Severity: major Version: 5.2
Component: Site Health Keywords: site-health
Focuses: Cc:

Description

Hello,

our server is CentOS 7.6, curl version is 7.29.0 and we have this error:
cURL error 28: Operation timed out after 10001 milliseconds with 0 bytes received

This appears in the Site Health check page.
We tried also with firewall completely down, but nothing changes.

We are an Hosting Company and we have many customers that are encountering this issue.

Can you please check it?

Change History (11)

This ticket was mentioned in Slack in #hosting-community by spacedmonkey. View the logs.


3 years ago

#2 @Clorith
3 years ago

  • Component changed from General to Administration
  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed
  • Version changed from 5.2.1 to 5.2

Hi there, and welcome to the WordPress Trac!

Loopback issues often affect things such as WP_Cron (scheduled posts, automatic updates) and similar, but can also have other impacts.

The reasons for the mfailing can be varied, in some cases it can be a configuration error form the host (not letting your own server make requests to it self due to load balancers, bad DNS setups and so forth), but it's also not uncommon that plugins or themes have code that in some manner interrupt these requests.

You mentioned "many", but not "all", so I'll presume that plugins or themes are the root cause in your situation, in those cases you can recommend they follow the troubleshooting steps as outlined in the support teams WordPress 5.2 Master List.

#3 @nirvak
3 years ago

  • Resolution invalid deleted
  • Status changed from closed to reopened

Hello Clorith,

I can reproduce this issue even with a new clear Wordpress 5.2 installation, no plugin or themes at all.
I mentioned many and not all, because on our CentOS 6 servers (older curl version), this check is correctly completed.

#4 @Clorith
3 years ago

  • Keywords site-health added

I would ask that you to look at the setup then, if it works on some of your servers, but not all, as I'm unfortunately unable to replicate this. If you can provide more details I'd be happy to troubleshoot further, but I would need some more to go on for that.

#5 @capbussat
3 years ago

I have the same issue with my Plugin 'Mis Cursos' https://wordpress.org/plugins/mis-cursos/ gives error in Health Site page.

cURL error 28: Operation timed out after

I may change slightly my code to avoid session lock conflict with REST API . I have tested locally and so far message dissapears from Health Site page, but then I see PHP notices in error log like PHP Warning: session_start(): Cannot start session when headers already sent in.

<?php
// session
function mis_cursos_register_session(){
     if( !session_id() )
       session_start();
}

// session
function mis_cursos_destroy_session() {
     // generally better than UNSET each session variable
     session_destroy ();
}

if ( !is_admin() ){  // DONE avoid session locks with REST_API !
    add_action('init','mis_cursos_register_session'); 
    add_action('wp_logout', 'mis_cursos_destroy_session');
    add_action('wp_login', 'mis_cursos_destroy_session'); 
}

#6 @nirvak
3 years ago

Hello,

I solved the issue.
It was the plugin "WP GDPR".

Deactivating it, solved the problem.

#7 @Clorith
3 years ago

  • Resolution set to invalid
  • Status changed from reopened to closed

I'm closing this ticket again as the reporter found the problem on their end.

@capbussat if you need help with your code, I'd recommend opening a ticket on our support forums.

#8 @spacedmonkey
3 years ago

  • Component changed from Administration to Site Health

#9 @mertozsoy
2 years ago

  • Resolution invalid deleted
  • Severity changed from major to critical
  • Status changed from closed to reopened

I'm having the same problem. No solution?

#10 @spacedmonkey
2 years ago

  • Severity changed from critical to major

Downgrading this ticket as critical is reserved for issues that effect all of WP, which this does not.

#11 @desrosj
16 months ago

  • Resolution set to invalid
  • Status changed from reopened to closed

Closing out again as this is still not the right place to address this. @mertozsoy if you are still experiencing this, please open a ticket on the WordPress.org support forum.

Note: See TracTickets for help on using tickets.