WordPress.org

Make WordPress Core

Opened 7 years ago

Closed 7 years ago

#4744 closed defect (bug) (invalid)

RSS Feed Widget: No feeds work.

Reported by: cafeman Owned by: matt
Milestone: Priority: normal
Severity: normal Version: 2.2.2
Component: General Keywords: RSS Feed
Focuses: Cc:

Description

Site: http://yo.landyo.us
Host: Aplus.net
Versions: PHP/MySQL, confirmed ok
Wordpress Version: 2.2.2

Whenever I place a feed into the feed widget, I get a message that an error occured, the feed is probably down, and to try later. All these feeds work on my other blog at http://meetkendall.com, which is hosted on wordpress.com.

Perhaps I should open another ticket for this but it may be related. If you go to the above domain and click on Entries RSS or Comments RSS, nothing shows up with it saying, "Internet Explorer cannot display this feed." Thank you and sorry to bother you with this.

I used the standard installation from Aplus.net to install Wordpress. However, i was not completely sure of the version, so I reinstalled it myself from a download fresh from wordpress.org today. I also installed the KB Advanced RSS Widget to see if it would work and there is no luck with that either, it has the same error messages.

Change History (8)

comment:1 DD327 years ago

When you open the WP Dashboard, Does the Feeds open in there (Current News, Events, Etc)?

If not, then its most likely that the code cannot access remote files, it might be that a security limitation has been put in place or something else, which would most likely be specific to your host

D

comment:2 cafeman7 years ago

Thank you for the fast response. Yes, when I go to the dashboard, it allows you to see a feed from wordpress.org, including what appears to be posts from the wordpress blog, etc. My blog allows anyone to get a username/password. Feel free to get one here: http://yo.landyo.us/wp-login.php?redirect_to=%2Fwp-admin%2F.

One thing that may be an indicator is that I tried installing the wordpress stats module which requires an API key. When I enter the API key from wordpress, I get the following error:

Error from last API Key attempt:

Your blog was unable to connect to WordPress.com. Please ask your host for help. (transport error - could not open socket: 13 Permission denied)

Do you think this is related to my potential problem?

comment:3 DD327 years ago

It looks to be that your webhost is blocking outgoing requests from the webserver, OR a security module is kicking in on the hosters end.

Also, it seems that "WordPress Development Blog" is displaying old data, which probably means it cant access the new data either. (Whys its caching old data i'm not sure, once again, your webhost might be running some form of cache).

I'd recomend to get in touch with your host and ask about it, Its not a specific WordPress issue by the looks of it, And probably would've been better suited t the Support Forums rather than Trac.

D

comment:4 cafeman7 years ago

Quickly, I've contacted my host partner and that may be the problem. The reason I came to Trac was that there is a very long post on the Support Forum and no one was getting any answers. See http://wordpress.org/support/topic/120458?replies=18#post-602781. I shall hopefully close this withing a couple of hours. I cannot tell you how happy I am that you're trying to help me...

comment:5 cafeman7 years ago

  • Resolution set to fixed
  • Status changed from new to closed

My hosting provider (aplus.net) opened a port to the proper IP/Port number to allow RSS feeds. This was not a problem with Wordpress technology. THANK YOU SO MUCH FOR HELPING ME!!!

comment:6 cafeman7 years ago

Though I closed this moments ago, please see thread on:
http://wordpress.org/support/topic/120458?replies=21#post-602852

comment:7 Nazgul7 years ago

  • Resolution fixed deleted
  • Status changed from closed to reopened

comment:8 Nazgul7 years ago

  • Component changed from WordPress.org to General
  • Milestone 2.2.3 deleted
  • Resolution set to invalid
  • Status changed from reopened to closed

Glad we could help.

Marking tickets as fixed is for changes in the code. I'll mark it as invalid as it wasn't a Wordpress issue.

Note: See TracTickets for help on using tickets.