Make WordPress Core

Opened 4 years ago

Closed 4 days ago

#47442 closed defect (bug) (worksforme)

Twitter auto-embed fails if twitter username contains Emoji icon

Reported by: dijkenwater's profile dijkenwater Owned by:
Milestone: Priority: normal
Severity: normal Version: 5.2.1
Component: Embeds Keywords: reporter-feedback
Focuses: Cc:


Every time we add a Twitter link to our articles, the embedded (auto-embed) tweets stop working after a while. this happens only, when the username contains a emoji icon. All other tweets works fine. Adding the embed code from twitter works also fine (with emoji in username)

Change History (4)

#1 @desrosj
4 years ago

  • Keywords reporter-feedback added

Hi @dijkenwater,

Welcome to Trac!

Can you provide some more details to help others reproduce the issue? I tried, but have been unable to reproduce in my testing. I have tried embedding tweets where usernames contain emojis in the block editor using the Twitter embed block, the Classic Editor block, and the Classic Editor.

You mentioned that they work and then stop after a while. Have you been able to determine what stops them from working? Also, when they do not work, is there any browser level ad blocker or tracking script prevention running?

#2 @dijkenwater
4 years ago

Hi @desrosj ,

i add for example 10 Links with tweets to an article. After Publishing everything works fine. And after a while the embed tweets with emojis in the usernames are displayed as a link in the article and not as a embeded tweet.

I'm working with the Code-Editor.

Last edited 4 years ago by dijkenwater (previous) (diff)

#3 @dijkenwater
4 years ago

Here is an update. If the username contains Special Characters like "𝑔𝒾𝓃𝒶 💋‏" there is also a problem embedding the tweet.

#4 @swissspidy
4 days ago

  • Milestone Awaiting Review deleted
  • Resolution set to worksforme
  • Status changed from new to closed

I cannot reproduce this issue either, might be specific to this particular setup.

Note: See TracTickets for help on using tickets.