WordPress.org

Make WordPress Core

#47469 closed defect (bug) (invalid)

Shortcodes not working

Reported by: frizzant Owned by:
Milestone: Priority: normal
Severity: major Version: 5.2.1
Component: Shortcodes Keywords:
Focuses: Cc:

Description

Shortcodes seem to be displaying on a pure installation, but not on others.

Works on: Old WP Version which has been updatet to 5.2.1
Does not work on: Old WP Version which has been updated to 5.2.1, and on fresh install WP Version 5.2.1

Different themes have been applied and tested. These have no influence on this.

Change History (3)

#1 @desrosj
23 months ago

  • Focuses administration template removed
  • Keywords reporter-feedback added

Hi there @frizzant,

Welcome to Trac!

Can you please provide more details to help others reproduce your issue? In my testing, I have not been able to reproduce the issue.

Some questions:

  • What shortcode are you trying to use?
  • Are you sure that the shortcode you are using is a default shortcode included with WordPress Core and not one included with a plugin or theme?
  • Can you clarify what you mean when you say "Old WP Version which has been updated to 5.2.1"?
  • It is unclear to me what the differences are between the sites that work and the ones that do not. It seems that the first is an upgraded site and the second one is a fresh install?
  • Can you clarify where you are expecting them to be rendered, where they are do render (if at all), and where they do not?

#2 @frizzant
23 months ago

Hello @desrosj

It's very hard for me to comprehend it. But i'll do my best.
I tried a few shortcodes, one of which was [sitemap] which by my knowledge should work by default. I also installed Jetpack, because I wasn't sure if it was included in there, just to be sure.

Working old version: By old, I mean a Wordpress Version of ~2 Years, that was continuously updated.
Non-working old version: can't tell the age, but it must be at least 6 years of age, but updated now.

Since I developed the theme, and I tested it on all three WP instances, I can safely say, not it is not within the theme. To be sure if it didn't work on the "non-working" wordpress instance, I installed twenty-nineteen theme, with which it did not work either.

So basicly I was able to rule out anything theme related as an issue.

The goal was to render a shortcode on a single-page. But any place I tried, it did not seem to work.

I am assuming that both of these non working Wordpress versions were installed "automatically". One of them is hosted on metanet.ch, the other is a local dev. version installed with "Local by Flywheel".

Last edited 23 months ago by frizzant (previous) (diff)

#3 @desrosj
23 months ago

  • Keywords reporter-feedback removed
  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed

Thanks for following up, @frizzant.

The [sitemap] shortcode is not included in WordPress Core. It's possible that the others are also not core shortcodes.

This seems like it is an issue on just your setup. I recommend opening a support ticket in the WordPress.org support forums to investigate further.

Note: See TracTickets for help on using tickets.