WordPress.org

Make WordPress Core

Opened 10 months ago

Closed 6 days ago

#47472 closed defect (bug) (invalid)

In Multisite plugins are loaded if active on main site even if not Network Enabled

Reported by: raftaar1191 Owned by:
Milestone: Awaiting Review Priority: normal
Severity: normal Version:
Component: Plugins Keywords: needs-patch
Focuses: multisite Cc:

Description

When we activate the plugin into the First sites of Multisites and then goes back to the Main network sites, We can see that the plugin that is activated on the first sites are getting auto Auto even if it's Network disable

Video Link: https://screencast-o-matic.com/watch/cq1erPTOBd

Change History (2)

This ticket was mentioned in Slack in #core-multisite by markparnell. View the logs.


6 days ago

#2 @markparnell
6 days ago

  • Focuses multisite added
  • Resolution set to invalid
  • Severity changed from critical to normal
  • Status changed from new to closed
  • Summary changed from In Multisites plugin getting auto Load even it is not Network Enable to In Multisite plugins are loaded if active on main site even if not Network Enabled

Hi @raftaar1191, thanks for the report! After discussion with @johnjamesjacoby I can confirm that this is the intended behaviour - the network admin area is loaded from that main site, so inherits its settings (including active plugins).

Note: See TracTickets for help on using tickets.