WordPress.org

Make WordPress Core

Opened 17 months ago

Closed 17 months ago

Last modified 17 months ago

#47508 closed defect (bug) (invalid)

Row number and column number needs to be swapped(Version 5.2.1 Language zh_CN)

Reported by: chfeng Owned by:
Milestone: Priority: normal
Severity: normal Version: 5.2.1
Component: Editor Keywords:
Focuses: Cc:

Description

Wordpress Version 5.2.1 Language zh_CN)

When I am create a table using the editor:

What I filled in:

行数:3
列数:2

Translated as:

Row number: 3
Column number: 2

However, the table I got is 3 columns 2 rows.

The row number and column number in the UI need to be swapped.

I am not sure whether this happens to other language or just Chinese version.

Attachments (3)

1.jpg (36.5 KB) - added by chfeng 17 months ago.
Create Table UI
2.jpg (14.8 KB) - added by chfeng 17 months ago.
english.JPG (34.8 KB) - added by chfeng 17 months ago.
English

Download all attachments as: .zip

Change History (6)

@chfeng
17 months ago

Create Table UI

@chfeng
17 months ago

#1 @chfeng
17 months ago

Please refer to the attachments for the screenshots.

#2 @SergeyBiryukov
17 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed

Hi @chfeng, welcome to WordPress Trac! Thanks for the report.

  • Row Count was indeed previously translated as 行数, the translation has been corrected to 列数 in December 2018.
  • Column Count was indeed previously translated as 列数, the translation has been corrected to 行数 in December 2018.

That said, a new language pack for zh_CN locale is still not available, as the translation is only 94% complete. It should be generated once the translation reaches 100% status.

Closing the ticket, as it's an issue with the translation, not with WordPress core.

@chfeng
17 months ago

English

#3 @chfeng
17 months ago

@SergeyBiryukov
Many thanks for the follow up. However, I am a little surprised.
Looks like the problem is not really on the translation per se. The previous translation was correct I believe: i.e. Row Count should be translated into "行数", and Column Count should be translated as "列数”. There is nothing wrong with that at all.

I had a look at the English version, see "English.jpg" in attachment.
The first row reads"column count",. As I said, the old translation is correct. So the first row should read "列数", But if you look at the Chinese UI, "列数" is on the 2nd row. So the issue is it was translated correctly but it has been put on the *wrong position* in the UI.

And now the “corrected” version is trying to "compensate" the wrong position with wrong translation.

Last edited 17 months ago by chfeng (previous) (diff)
Note: See TracTickets for help on using tickets.