WordPress.org

Make WordPress Core

Opened 14 years ago

Closed 14 years ago

#4754 closed defect (bug) (fixed)

Change log out message from "Successfully logged you out"

Reported by: hichaminooo Owned by: lloydbudd
Milestone: 2.5 Priority: lowest
Severity: trivial Version: 2.2.2
Component: Administration Keywords: has-patch
Focuses: Cc:

Description

The logout screen in version 2.2.2 displays the message as follows: Successfully logged you out

This need to be fixed to You logged out successfully

Attachments (4)

WP_2-2-2_logout_screen.jpg (104.1 KB) - added by hichaminooo 14 years ago.
wp-login.diff (912 bytes) - added by ninjaWR 14 years ago.
4754-you-have-been-successfully-logged-out.diff (914 bytes) - added by Speedboxer 14 years ago.
Change logout text to "You have been successfully logged out."
wp-login.php.diff (902 bytes) - added by spencerp 14 years ago.
patch includes "You are now logged out."

Download all attachments as: .zip

Change History (24)

#1 @foolswisdom
14 years ago

  • Milestone changed from 2.2.3 to 2.4 (future)
  • Summary changed from fixing log-out screen to txt logout screen You logged out successfully

#2 @foolswisdom
14 years ago

  • Priority changed from normal to lowest
  • Severity changed from normal to trivial

@ninjaWR
14 years ago

#3 @ninjaWR
14 years ago

  • Keywords has-patch added

So it's not a big change, or all that important... everyone's gotta start somewhere ;)

#4 @DD32
14 years ago

  • Keywords dev-feedback added

#5 @darkdragon
14 years ago

  • Summary changed from txt logout screen You logged out successfully to Change log out message to "You have logged out successfully"

#6 @lloydbudd
14 years ago

  • Keywords commit added; dev-feedback removed
  • Summary changed from Change log out message to "You have logged out successfully" to Change log out message from "Successfully logged you out"

#7 @lloydbudd
14 years ago

  • Keywords has-patch commit removed
  • Owner changed from anonymous to lloydbudd

On second thought the new phrase although better isn't that great either. Will research further

#8 follow-up: @Speedboxer
14 years ago

I believe "You have been successfully logged out" would be the most grammatically correct.

#9 in reply to: ↑ 8 ; follow-up: @spencerp
14 years ago

Replying to Speedboxer:

I believe "You have been successfully logged out" would be the most grammatically correct.

I agree with this one. Either that, or: "You've been successfully logged out." Or maybe even: "You have just successfully logged out." Or something like that. Come on people, let's make up the mind here... start committing patches and stuff... =P

#10 in reply to: ↑ 9 ; follow-up: @Speedboxer
14 years ago

Replying to spencerp:

I agree with this one. Either that, or: "You've been successfully logged out." Or maybe even: "You have just successfully logged out." Or something like that. Come on people, let's make up the mind here... start committing patches and stuff... =P

"You have..." is better than "You've..." is we really want to make it grammatically correct. ;)

#11 in reply to: ↑ 10 @spencerp
14 years ago

Replying to Speedboxer:

Replying to spencerp:

I agree with this one. Either that, or: "You've been successfully logged out." Or maybe even: "You have just successfully logged out." Or something like that. Come on people, let's make up the mind here... start committing patches and stuff... =P

"You have..." is better than "You've..." is we really want to make it grammatically correct. ;)

LOL! True! Me just wants most of these tickets pushed out the door... *cough* Use Speedboxers suggestion and go with it...whee!

@Speedboxer
14 years ago

Change logout text to "You have been successfully logged out."

#12 @Speedboxer
14 years ago

Patch 4754-you-have-been-successfully-logged-out.diff changes the logout text from "Successfully logged out." to the more grammatically correct "You have been successfully logged out."

#13 @Speedboxer
14 years ago

  • Keywords has-patch added

#14 @filosofo
14 years ago

I realize this has probably become a "bikeshed" ticket now, but isn't the "successfully" unnecessary? I have either logged out, or not.

My suggestion is short and avoids redundancy and the passive voice: "You have logged out."

#15 follow-up: @JDTrower
14 years ago

I tested 4754-you-have-been-successfully-logged-out.diff and it works as intended. The Log Out text was listed as "You have been successfully logged out."

Per the comment by filosofo, I don't think the word "successfully" is unnecessary. A user typically would want to know that they were successfully logged out not just that they logged out. I think it is probably a personal preference. I think the wording "You have been successfully logged out" is much better than the current "Successfully logged you out" message.

#16 in reply to: ↑ 15 @spencerp
14 years ago

Replying to JDTrower:

I tested 4754-you-have-been-successfully-logged-out.diff and it works as intended. The Log Out text was listed as "You have been successfully logged out."

Per the comment by filosofo, I don't think the word "successfully" is unnecessary. A user typically would want to know that they were successfully logged out not just that they logged out. I think it is probably a personal preference. I think the wording "You have been successfully logged out" is much better than the current "Successfully logged you out" message.

I agree totally. It's really a personal preference as to what it could/ should say in general. *Cough* Someone make a plugin for this, to allow admins ability to add custom logout messages. =P But yes, the general user(s) would want to know that they have been successfully logged out. Not just "logged out".

Successfully logged out = (to any general user) that they logged out totally and there's no doubt THEY ARE logged out. (It wouldn't leave doubts of "if they were really logged out or not" lingering in the mind...

#17 @ryan
14 years ago

"You are now logged out"

@spencerp
14 years ago

patch includes "You are now logged out."

#18 @spencerp
14 years ago

I added a patch that has "You are now logged out."

#19 @spencerp
14 years ago

If no one is going to do anything with this ticket, why not just delete it? I mean, seriously... =P

#20 @westi
14 years ago

  • Resolution set to fixed
  • Status changed from new to closed

(In [6566]) You are now logged out. Fixes #4754 props spencerp.

Note: See TracTickets for help on using tickets.