WordPress.org

Make WordPress Core

Opened 6 months ago

Closed 6 months ago

Last modified 6 months ago

#47553 closed defect (bug) (wontfix)

Can no longer enter 1 column in a columns block

Reported by: pattyok Owned by:
Milestone: Priority: normal
Severity: normal Version: 5.2
Component: Editor Keywords:
Focuses: Cc:
PR Number:

Description

Since WordPress 5.2 entering 1 into the number of columns and hit enter and the number changes to 2.

Allowing one column provides the ability to follow a simple design pattern. This is an easy way to achieve a common design pattern with a full bleed background and content in the center. Disallowing this pattern breaks many of my site layouts. This should be allowed.

Change History (5)

#1 @SergeyBiryukov
6 months ago

  • Component changed from Formatting to Editor

#2 follow-up: @earnjam
6 months ago

  • Keywords reporter-feedback added

According to the HTML Specification, this is not a permitted use of tables. A couple of excerpts from the spec:

The table element represents data with more than one dimension, in the form of a table.

Tables should not be used as layout aids.

So I would discourage the use of tables in this manner.

Having said that, when I just tested with WordPress 5.2.2, I was able to enter 1 for the initial count of columns or rows and have it insert a table with that value.

Can you confirm that this is occurring in a fresh install with the default theme and all plugins deactivated?

#3 in reply to: ↑ 2 @pattyok
6 months ago

Replying to earnjam:

Nothing to do with Tables, it is referring to the Columns block.

Confirming that the issue exists on a clean install with WP 5.2.2. Enter 1 into the number of columns field and when you click out of it, it changes to a 2.

#4 @earnjam
6 months ago

  • Keywords reporter-feedback removed
  • Milestone Awaiting Review deleted
  • Resolution set to wontfix
  • Status changed from new to closed

Ah, my apologies. I'm not sure where I got table from. 🙃

This is a duplicate of https://github.com/WordPress/gutenberg/issues/12400 and was an intentional decision, since the column block design and UX is focused on having 2+ columns. The fact that you could enter 1 directly into the field was a bug in the RangeControl component.

In Gutenberg there is now a Group block which can be used as a container and is better suited for your purpose. It's available in the Gutenberg plugin now and will be included with WordPress 5.3.

#5 @pattyok
6 months ago

But why? Why cant I have a one column layout? This breaks an attempt at providing patterns to design by and patterns to give to my clients to make consistent layouts.

Example. I have a two column layout, information in the second column may not always need to be displayed to remove a column they have to add another block, configure it and move the content over?

Its a simple pattern. What is the point of disallowing it? It just makes developing layouts and the users job more complicated.

I maintain that this should be fixed.

Note: See TracTickets for help on using tickets.