WordPress.org

Make WordPress Core

Opened 18 months ago

Closed 15 months ago

Last modified 3 months ago

#47587 closed defect (bug) (invalid)

Parent Page dropdown is missing in Page Attributes on Pages - WP 5.2.2

Reported by: pattyok Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Editor Keywords:
Focuses: Cc:

Description

In WP 5.2.2, on a clean install with no plugins, 2019 theme.

Create a new page or open a page for editing with the Block Editor

Expect to see the parent pages dropdown under the Page Attributes module.

Its not there.

Have to go to the Pages list, do a quick edit and change it there. (or add the classic editor plugin)

Change History (8)

#1 @earnjam
18 months ago

  • Keywords reporter-feedback added

Hi @pattyok. I tried to replicate on a brand new installation with 5.2.2. As long as there is at least 1 published page, then the parent page dropdown shows for me. If you delete all pages or move them to draft, then it doesn't display. You can only set a published page to a parent.

Can you confirm that you have at least one page published?

#2 @pattyok
18 months ago

  • Resolution set to invalid
  • Status changed from new to closed

Oh gosh yep. You are correct. The other page was a draft.

In trying to narrow down which plugin might be causing the issue, it looks like it is Advanced Custom Fields... I will go there...

Thanks

#3 @pattyok
18 months ago

Actually - in case anyone finds this.

The problem is with the Gallery Custom Links plugin. When that plugin is activated and a gallery has an item with a link applied to it, he wp-json response is not encoded correctly and therefore the wp-json request that is used to populate the drop down errors out.

#4 @pattyok
18 months ago

  • Keywords reporter-feedback removed

#5 @earnjam
18 months ago

  • Milestone Awaiting Review deleted

#6 follow-up: @aparker48
17 months ago

  • Resolution invalid deleted
  • Status changed from closed to reopened
  • Version set to 5.2.2

Sorry, but this is happening to me also with WP 5.2.2 and I have over 107 pages on the site and have used Health Check. When I turn on Health Check the parent pages drop-down magically appears on my editor pages. I can turn on ALL my plugins and as long as I have Health Check running, the Parent Page selection is available from the editor. Turn off Health Check and Parent Page selection disappears and it is back to publishing the page and going out to the page listings to use quick edit to set the parent. There is a problem in there somewhere, but I cannot find it. Please investigate this again and report any workarounds or fixes.

#7 in reply to: ↑ 6 @earnjam
15 months ago

  • Resolution set to invalid
  • Status changed from reopened to closed
  • Version 5.2.2 deleted

Replying to aparker48:

Sorry, but this is happening to me also with WP 5.2.2 and I have over 107 pages on the site and have used Health Check. When I turn on Health Check the parent pages drop-down magically appears on my editor pages. I can turn on ALL my plugins and as long as I have Health Check running, the Parent Page selection is available from the editor. Turn off Health Check and Parent Page selection disappears and it is back to publishing the page and going out to the page listings to use quick edit to set the parent. There is a problem in there somewhere, but I cannot find it. Please investigate this again and report any workarounds or fixes.

You need to check the console for javascript errors while in the editor. My guess is your situation is similar to the pattyok where a plugin is messing with the API response.

If the problem persists when you deactivate all plugins, then we can reopen and troubleshoot some more, but since this is almost certainly a plugin issue, your question would be better suited on the support forums.

Note: See TracTickets for help on using tickets.