WordPress.org

Make WordPress Core

Opened 4 months ago

Closed 4 months ago

Last modified 4 months ago

#47592 closed defect (bug) (invalid)

Warning: Header may not contain NUL bytes in /app/wp-login.php on line 12

Reported by: sebastienserre Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Login and Registration Keywords:
Focuses: Cc:
PR Number:

Description

Hello,

I'm on a local env under https://docs.devwithlando.io/ PHP 7.3.6

I'm installing a new WP and got this error

Warning: Header may not contain NUL bytes in /app/wp-login.php on line 12

which is this part of code

<?php
// Sanity check.
if ( false ) {
        ?>
<!DOCTYPE html>
<html xmlns="http://www.w3.org/1999/xhtml">
<head>
        <meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
        <title>Error: PHP is not running</title>
</head>
<body class="wp-core-ui">
        <p id="logo"><a href="https://wordpress.org/">WordPress</a></p>
        <h1>Error: PHP is not running</h1>
        <p>WordPress requires that your web server is running PHP. Your server does not have PHP installed, or PHP is turned off.</p>
</body>
</html>
        <?php
}

Change History (3)

#1 @sebastienserre
4 months ago

  • Keywords close added
  • Resolution set to invalid
  • Status changed from new to closed

I Think it was a matter on my own install as I can't reproduce it on another

#2 @pento
4 months ago

  • Keywords close removed
  • Milestone Awaiting Review deleted

Thanks for the bug report and update, @sebastienserre! Out of curiosity, I did a little more digging, looks like this was a bug in XDebug 2.7.0-RC2, now fixed.

#3 @SergeyBiryukov
4 months ago

  • Component changed from General to Login and Registration
Note: See TracTickets for help on using tickets.