Make WordPress Core

Opened 4 years ago

Closed 8 months ago

#47597 closed defect (bug) (reported-upstream)

Feature request to Video Block. Allow to specify alternative video formats when uploading media elements.

Reported by: cflornet's profile cflornet Owned by:
Milestone: Priority: normal
Severity: normal Version: 5.2.2
Component: Editor Keywords:
Focuses: Cc:

Description (last modified by SergeyBiryukov)

Hi,

I have a feature to suggest to the video block: to add alternate video formats.
As it is with shortcodes: [video webm="video.webm" mp4="video.mp4"] or some themes or html5:

 <video controls>
  <source src="movie.webm" type="video/webm">
  <source src="movie.mp4" type="video/mp4">
 </video>  

Something like this:

<!-- wp:video {"id":0001} -->
<figure class="wp-block-video"><video controls src="video.webm" src="video.mp4"></video></figure>
<!-- /wp:video --> 

Thanks for your work!

Change History (3)

#1 @SergeyBiryukov
4 years ago

  • Component changed from Upload to Media
  • Description modified (diff)

This ticket was mentioned in Slack in #core-media by desrosj. View the logs.


4 years ago

#3 @sabernhardt
8 months ago

  • Component changed from Media to Editor
  • Milestone Awaiting Review deleted
  • Resolution set to reported-upstream
  • Status changed from new to closed
  • Type changed from feature request to defect (bug)

Thanks for the report! The issue is already opened in Gutenberg repository, but it has not been completed.
https://github.com/WordPress/gutenberg/issues/9457

If you would like to follow that or join the discussion, please visit that page.

Note: See TracTickets for help on using tickets.