WordPress.org

Make WordPress Core

Opened 6 months ago

Closed 4 months ago

#47602 closed defect (bug) (duplicate)

Provide a way for block authors to allow content into the excerpt from a columns type block.

Reported by: britner Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Editor Keywords:
Focuses: Cc:
PR Number:

Description

Hey!

I would like a way for block authors to allow their nested blocks to be used to render the excerpt. I know that you can allow specific blocks to be rendered but if the block structure is similar to core columns blocks the content is ignored. This is because core columns have specific code in place to allow their content to be used. I don't understand why it's set up this way for only core columns to get their inner blocks checked.

https://core.trac.wordpress.org/browser/tags/5.2/src/wp-includes/blocks.php#L164

I also don't understand why only core blocks are allowed inside inner content? There is no filter for the $allowed_inner_blocks variable.

If this is something I can help with I would be happy to submit a pull request.

Change History (2)

#1 @SergeyBiryukov
5 months ago

  • Component changed from General to Editor

#2 @noisysocks
4 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Thanks for the ticket @britner!

The code that generates excerpts needs to be enhanced to cover more types of group blocks. This was first noted in #46133 and is now tracked in #47637.

I've marked this as a duplicate of #47637.

Note: See TracTickets for help on using tickets.