WordPress.org

Make WordPress Core

Opened 5 months ago

Closed 2 months ago

#47636 closed defect (bug) (worksforme)

Copy-paste trim issue with Gmail

Reported by: djavet Owned by:
Milestone: Priority: normal
Severity: normal Version: 5.2.2
Component: Editor Keywords:
Focuses: administration Cc:
PR Number:

Description

How to reproduce:
Copy a texte from Gmail:

Our "DATA MIRAGE TANGRAM SPRING TOUR" ended at the mighty Hellfest, on July 23rd.
Thank you all, it has been a wonderful musical adventure and a great human experience.
Here is a video report of our day at Hellfest by Renaud Ruhlman:

The lines are in DIVs. And paste this text in WP post, in a paragraph block. The DIVs are trim away and the lines return are displayed on a single line without a space before each line.
In WP block, you have now:

 Our "DATA MIRAGE TANGRAM SPRING TOUR" ended at the mighty Hellfest, on July 23rd.Thank you all, it has been a wonderful musical adventure and a great human experience.Here is a video report of our day at Hellfestby Renaud Ruhlman:

Notice:

  • the space before the very first letter
  • no space for each line "23rd.Thank" or "experience.Here"

How it should be:

  • No space before the very first letter
  • a space for each line: "23rd. Thank" or "experience. Here"

Attachments (2)

Capture.PNG (41.1 KB) - added by djavet 5 months ago.
Capture1.PNG (18.8 KB) - added by djavet 5 months ago.

Download all attachments as: .zip

Change History (5)

@djavet
5 months ago

@djavet
5 months ago

#1 follow-up: @anuj2
2 months ago

I tried the same with given text as well as some other texts from gmail, but was not able to reproduce the bug.

#2 in reply to: ↑ 1 @djavet
2 months ago

Replying to anuj2:

I tried the same with given text as well as some other texts from gmail, but was not able to reproduce the bug.

Seems it's fixed in 5.2.3, cannot reproduce it. Cool!

#3 @SergeyBiryukov
2 months ago

  • Component changed from General to Editor
  • Milestone Awaiting Review deleted
  • Resolution set to worksforme
  • Status changed from new to closed

Welcome to WordPress Trac! Thanks for the follow-up :)

Note: See TracTickets for help on using tickets.