WordPress.org

Make WordPress Core

#47643 closed defect (bug) (duplicate)

Problem with W3C Validation

Reported by: peter120 Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Script Loader Keywords:
Focuses: Cc:

Description

Dear support,

Had to create an account for this, so I did.

I like to ask if it would be possible to code out the script type warning we get when running a W3C HTML test.

I have this with GeneratePress as with other themes and most creators ask us to contact WordPress support and to let them know, as this might be inside the core part of WP.

Here is some source I found that talks about this as well:
https://generatepress.com/forums/topic/problem-with-w3-validation/

His link shows a lot of errors that are not related to core I think but to his theme.

However, most developers think that the following is related to core:

Warning: The type attribute for the style element is not needed and should be omitted.

There seems to be a temporary solution and it does work in my testing environment. The problem is that it suggest using PHP Buffering, and I have no idea if this is hammering our page-load speed in a negative way:

https://wordpress.stackexchange.com/questions/287830/remove-type-attribute-from-script-and-style-tags-added-by-wordpress/287833#287833

Thanks for making WordPress. I cannot live without it and am thankful everyday that this has been created!

Hope this info helps.

Regards.

Change History (3)

#2 @peter120
15 months ago

  • Component changed from General to Bootstrap/Load

#3 @SergeyBiryukov
15 months ago

  • Component changed from Bootstrap/Load to Script Loader
  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Hi @peter120, welcome to WordPress Trac!

Thanks for the report, we're already tracking this issue in #42804.

Note: See TracTickets for help on using tickets.