WordPress.org

Make WordPress Core

Opened 7 months ago

Closed 6 weeks ago

#47649 closed defect (bug) (duplicate)

Issue with the stack order of color picker handle

Reported by: balachandark Owned by:
Milestone: Priority: normal
Severity: minor Version:
Component: Customize Keywords: reporter-feedback
Focuses: Cc:
PR Number:

Description

The issue is that the color picker handle has been set as follows:
.iris-picker-inner{position:absolute;top:0;right:0;left:0;bottom:0} from the iris.min.js file. But a z-index value has not been provided to it so it overlaps the overlay sidebar content. To overcome this issue we can add CSS property z-index: 8 to it so that it stays beneath the sidebar content. Please refer this video - https://cl.ly/1b1643920c05

Attachments (2)

iris.min.js (23.1 KB) - added by balachandark 7 months ago.
iris.min.js
iris.min.2.js (23.1 KB) - added by balachandark 7 months ago.
iris.min.js ( tested )

Download all attachments as: .zip

Change History (5)

@balachandark
7 months ago

iris.min.js

@balachandark
7 months ago

iris.min.js ( tested )

#1 @SergeyBiryukov
7 months ago

  • Component changed from General to Customize

#2 @dlh
6 weeks ago

  • Focuses ui removed
  • Keywords reporter-feedback added; needs-patch removed
  • Version 5.2.2 deleted

@balachandark, are you able to provide a code sample that can be used to show the issue with no plugins activated and a default theme?

Separately, Iris is a third-party library, and changes to the library should be submitted at its GitHub repo. However, a patch could still be made to the Customizer CSS to account for Iris's styles if the bug is reproducible.

#3 @dlh
6 weeks ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Actually, it seems as though this is a duplicate of #43168.

Note: See TracTickets for help on using tickets.