WordPress.org

Make WordPress Core

Opened 8 months ago

Closed 8 months ago

Last modified 8 months ago

#47660 closed defect (bug) (invalid)

Displaying user data in the comment form at the site

Reported by: matejstrnad Owned by:
Milestone: Priority: normal
Severity: normal Version: 5.2.2
Component: Comments Keywords:
Focuses: privacy Cc:

Description

The page shows user data in the form for comments, there is no problem with posts.
WordPress version:5.2.2
PHP version: 7.3
template:Twenty Nineteen

Change History (7)

#1 @SergeyBiryukov
8 months ago

  • Focuses privacy added
  • Keywords reporter-feedback added

Hi @matejstrnad, welcome to WordPress Trac! Thanks for the report.

It's not quite clear what you mean by "user data", could you elaborate please? What are the steps to reproduce the issue on a clean install?

#2 @matejstrnad
8 months ago

I think the forms were completed. I'm not sure about that reproduction, maybe it would help save the data when posting comments on posts and allowing comments on a page.

#3 @knutsp
8 months ago

Do you mean that the comment form (on pages, at least) is pre-filled with name, email and website information? If so, they originated form a cookie set in the visitors browser, after having commented on the site recently, I believe.

If this is not what you mean, please explain in further detail and how to see it, and upload a screenshot of the form and data.

#4 @matejstrnad
8 months ago

I personally do not understand it, it was displayed to all people and it was not my data, it was the user who last commented. Because of GDPR, I disabled comments on that page. When I turned it on now it wasn't there anymore. As for the data, there was name, e-mail and the web.

#5 @knutsp
8 months ago

  • Keywords reporter-feedback removed
  • Resolution set to invalid
  • Status changed from new to closed

Do you use any caching plugin? Any plugins active at all?

If caching, please use the support forum for that plugin to get help.

If any plugins active, and this happens again, please try with all of them deactivated.

This Trac is for recording and fixingbugs, not indivual help. Unless there is a way to reproduce this behaviour on a clean installation (no plugins, default theme) there is little we can do here.

Please try our support forums https://wordpress.org/support/welcome/ to get help. If it turns out it might be a bug in WordPress, feel free to come back an reopen this ticket.

Last edited 8 months ago by knutsp (previous) (diff)

#6 @desrosj
8 months ago

  • Milestone Awaiting Review deleted

#7 @SergeyBiryukov
8 months ago

  • Severity changed from critical to normal
Note: See TracTickets for help on using tickets.