WordPress.org

Make WordPress Core

Opened 3 months ago

Closed 3 months ago

#47724 closed defect (bug) (duplicate)

International closing quotation marks are broken if surrounded by HTML Tags and punctuation marks

Reported by: apermo Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Formatting Keywords:
Focuses: Cc:
PR Number:

Description

<!-- wp:paragraph -->
<p>lorem ipsum "<strong>text in correct quotation marks</strong>" dolor.</p>
<!-- /wp:paragraph -->

<!-- wp:paragraph -->
<p>lorem ipsum "<strong>text in broken quotation marks</strong>".</p>
<!-- /wp:paragraph -->

<!-- wp:paragraph -->
<p>lorem ipsum "text in correct quotation marks".</p>
<!-- /wp:paragraph -->

Screenshot made using the snippet in WP 5.2.2 with latest twentynineteen, locale set to de_de.

I already discussed with @swisspidy and @tobifjellner on slack about it, and most likely it's a bug, the function replacing the normal " with the local opening or closing quotation marks has an issue as soon as html tags are next to them.

Attachments (1)

image (1).png (23.9 KB) - added by apermo 3 months ago.
Screenshot made using the attached Demo content in WP 5.2.2 with latest twentynineteen, locale set to de_de.

Download all attachments as: .zip

Change History (6)

@apermo
3 months ago

Screenshot made using the attached Demo content in WP 5.2.2 with latest twentynineteen, locale set to de_de.

This ticket was mentioned in Slack in #core-i18n by apermo. View the logs.


3 months ago

#2 @tobifjellner
3 months ago

  • Component changed from General to Formatting

It's about wptexturize()

#3 @apermo
3 months ago

Maybe related or duplicate to:
#18549
#29882

Last edited 3 months ago by SergeyBiryukov (previous) (diff)

#4 @audrasjb
3 months ago

  • Version 5.2.2 deleted

#5 @pento
3 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Aye, this is a duplicate of #18549. Thank you for the report, @apermo!

Note: See TracTickets for help on using tickets.