WordPress.org

Make WordPress Core

#47750 closed defect (bug) (invalid)

'x' changes to Multiplication sign when it's between numbers in Post Title

Reported by: dibbyo456 Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Formatting Keywords:
Focuses: Cc:

Description

When you create post with title 1080x2340 or '400x500', WordPress changes the 'x' to Multiplication sign (×) while output.

How to reproduce:

1) Create a post with Title '400x500' (Remember you need to put the 'x' between numbers without any spaces just like the example I gave).

2) Now open the post in browser you would able to the see 'x' is transformed to multiplication sign (×)

=====

Pictures for better understanding.

https://s.put.re/kKiXHksC.png
https://s.put.re/pyvRQw9q.png
https://s.put.re/kWD7W9gQ.png

Change History (2)

#1 @AkSDvP
10 months ago

@dibbyo456 Although I was not able to reproduce the issue at my end, I believe
html_entity_decode() in your template code could be sufficient enough to solve your question.

Honestly, I do not see any sort of issue or so.

#2 @ocean90
10 months ago

  • Component changed from General to Formatting
  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed
  • Version 5.2.2 deleted

Hello @dibbyo456, welcome to WordPress Trac!

The behaviour you're seeing is by design and is produced by wptexturize() which is hooked into the the_title filter.

Note: See TracTickets for help on using tickets.