WordPress.org

Make WordPress Core

Opened 3 months ago

Closed 3 months ago

Last modified 3 months ago

#47772 closed defect (bug) (invalid)

Too few arguments: class-bulk-upgrader-skin.php

Reported by: subrataemfluence Owned by:
Milestone: Priority: normal
Severity: normal Version: 5.2.2
Component: Plugins Keywords:
Focuses: Cc:
PR Number:

Description

Probably this issue has already been addressed before or may be this is not at all a core issue.

However, I am getting the following error:
wp-admin\includes\class-bulk-upgrader-skin.php on line 150
when installing Newsletter plugin.

The plugin was last modified 2 weeks ago, so I can assume it is an updated one.

Since there is no suitable option under Type I had to mark it as defect.

Change History (5)

#1 @subrataemfluence
3 months ago

Sorry! The line number is 153, not 150.

#2 follow-up: @dkarfa
3 months ago

Hey @subrataemfluence
I test with WordPress [5.3-alpha-20190723.165447] and it working fine.
Thanks :)

#3 in reply to: ↑ 2 @subrataemfluence
3 months ago

Thank you for checking on this. Does this mean the fix is coming with 5.3? I don't know how feasible is this for you, but is there any possibility that you can please try the same on 5.2.2 once? :)

Replying to dkarfa:

Hey @subrataemfluence
I test with WordPress [5.3-alpha-20190723.165447] and it working fine.
Thanks :)

#4 follow-up: @SergeyBiryukov
3 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed

Hi @subrataemfluence, thanks for the ticket!

Looking at the similar support forums report, this appears to be an issue with some plugins and themes using an older version of TGM Plugin Activation library, which doesn't account for the changes in [40646].

Before [40646], $this->upgrader->strings['skin_update_successful'] used to contain two string placeholders and the subsequent sprintf() call had two parameters. Now it only has one.

TGM Plugin Activation fixed this two years ago, however plugins or themes using an older version would still display the warning. FWIW, the Newsletter plugin doesn't seem to be the culprit here, I couldn't reproduce the issue after installing it. Looking at the changelog, the plugin did use the TGMPA library at some point, but it was removed in version 4.7.9, and the current version is 6.1.2. The issue might be in one of the other plugins or the theme you're using.

Going to close the ticket, as it's not a WordPress core issue.

#5 in reply to: ↑ 4 @subrataemfluence
3 months ago

Thank you @SergeyBiryukov for explaining the issue. I too had the same doubt that the problem is not related to the core. :)

Replying to SergeyBiryukov:

Hi @subrataemfluence, thanks for the ticket!

Looking at the similar support forums report, this appears to be an issue with some plugins and themes using an older version of TGM Plugin Activation library, which doesn't account for the changes in [40646].

Before [40646], $this->upgrader->strings['skin_update_successful'] used to contain two string placeholders and the subsequent sprintf() call had two parameters. Now it only has one.

TGM Plugin Activation fixed this two years ago, however plugins or themes using an older version would still display the warning. FWIW, the Newsletter plugin doesn't seem to be the culprit here, I couldn't reproduce the issue after installing it. Looking at the changelog, the plugin did use the TGMPA library at some point, but it was removed in version 4.7.9, and the current version is 6.1.2. The issue might be in one of the other plugins or the theme you're using.

Going to close the ticket, as it's not a WordPress core issue.

Note: See TracTickets for help on using tickets.