WordPress.org

Make WordPress Core

Opened 7 weeks ago

Closed 7 weeks ago

#47792 closed defect (bug) (duplicate)

Add backward compatibility to WP_REST_Server::check_authentication()

Reported by: brbrr Owned by:
Milestone: Priority: normal
Severity: normal Version: trunk
Component: REST API Keywords:
Focuses: Cc:

Description

#46907 changed the public method signature for WP_REST_Server::check_authentication() which breaks backward compatibility.

We should switch to an optional parameter in check_authentication to make sure the method works in older versions

Change History (1)

#1 @ocean90
7 weeks ago

  • Component changed from General to REST API
  • Keywords needs-patch removed
  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Hello @brbrr, welcome to WordPress Trac!

Thanks for your report. I'm closing it as a duplicate of #46907 to keep the discussion at one place.

Note: See TracTickets for help on using tickets.