WordPress.org

Make WordPress Core

Opened 4 months ago

Closed 3 months ago

#47811 closed enhancement (fixed)

Twenty Nineteen: Improve compatibility with custom colors in the separator block.

Reported by: kjellr Owned by: SergeyBiryukov
Milestone: 5.3 Priority: normal
Severity: normal Version:
Component: Bundled Theme Keywords: has-patch needs-testing
Focuses: Cc:
PR Number:

Description (last modified by kjellr)

There's a new Gutenberg feature that adds custom color support to the separator block:

https://github.com/WordPress/gutenberg/pull/16784

The custom color functionality added in that ticket is incompatible with Twenty Nineteen. The theme's styles override the custom colors in a couple places, and result in a mismatch between the front end and the editor. I'm attaching a small patch to fix that.

The separator color functionality is set for the 6.3 release of Gutenberg, so this should be fixed in Twenty Nineteen before that version is merged in, in order to ensure that the theme works with that functionality at launch.


To test:

  • Run a development version of Gutenberg with master active (or, wait until Gutenberg 6.3 is available in plugin form, and test with that)
  • Start a post with all three styles of the separator block. Ensure that by default, these appear as intended in the editor and in the front end.
  • Using the new sidebar controls, assign a color to each of the separators, and ensure that the new color shows up in the editor and in the front end.

Before

Editor

https://cldup.com/guK2WwJvwB-3000x3000.png

Front End

https://cldup.com/Fpbel8TYAm-3000x3000.png

After

Editor

https://cldup.com/zukGKwF6NN-3000x3000.png

Front End

https://cldup.com/sbs8Tnfods-1200x1200.png

Attachments (1)

47811.patch (3.6 KB) - added by kjellr 4 months ago.

Download all attachments as: .zip

Change History (4)

@kjellr
4 months ago

#1 @kjellr
4 months ago

  • Description modified (diff)

#2 @SergeyBiryukov
4 months ago

  • Milestone changed from Awaiting Review to 5.3

#3 @SergeyBiryukov
3 months ago

  • Owner set to SergeyBiryukov
  • Resolution set to fixed
  • Status changed from new to closed

In 45920:

Twenty Nineteen: Improve compatibility with custom colors in the separator block.

Props kjellr.
Fixes #47811.

Note: See TracTickets for help on using tickets.