WordPress.org

Make WordPress Core

Opened 16 months ago

Closed 3 weeks ago

#47903 closed defect (bug) (worksforme)

Linktext with formatting (<sub>) is split into separate links

Reported by: mlinhuberin Owned by:
Milestone: Priority: normal
Severity: normal Version: 5.2.2
Component: Editor Keywords:
Focuses: Cc:

Description

CO2-Steuer as linktext results in:

<a href="#link">CO</a><sub><a href="#link">2</a></sub><a href="#link">-Steuer</a>

Change History (1)

#1 @noisysocks
3 weeks ago

  • Milestone Awaiting Review deleted
  • Resolution set to worksforme
  • Status changed from new to closed

Hi @mlinhuberin. I was not able to reproduce this using the classic editor or the block editor.

This is what I did, with the block editor enabled:

  1. Created a new post.
  2. Typed CO-Steuer.
  3. Selected CO and toggled on Subscript in the More rich text controls menu.
  4. Selected CO-Steuer and created a link using the Link button in the toolbar.
  5. Opened the Code editor.

This is what I did, with the block editor disabled:

  1. Created a new post.
  2. Opened the Text view.
  3. Manually replaced CO with <sub>CO</sub>.
  4. Opened the Visual view.
  5. Selected CO-Steuer and created a link using the Link button in the toolbar.
  6. Opened the Text view.

In both cases the markup was <a href="http://example.com"><sub>CO</sub>-Steuer</a>.

Note: See TracTickets for help on using tickets.