WordPress.org

Make WordPress Core

Opened 2 years ago

Closed 4 weeks ago

Last modified 3 weeks ago

#47934 closed defect (bug) (worksforme)

Undefined property: wpdb::$blogmeta

Reported by: malthert Owned by:
Milestone: Priority: normal
Severity: normal Version: 5.2.2
Component: Database Keywords: reporter-feedback
Focuses: Cc:

Description (last modified by SergeyBiryukov)

Happened when updating from 4.9.7 to 5.2.2:

Error: Undefined property: wpdb::$blogmeta

Error in: /wp-includes/wp-db.php on line 618
Url: /wp-admin/upgrade.php?step=upgrade_db

Stack trace:
#0 /wp-admin/includes/schema.php (270): wpdb->__get( $name = blogmeta )
#1 /wp-admin/includes/schema.php (353): wp_get_db_schema( $scope = all )
#2 /wp-admin/includes/upgrade.php (20): require_once( /wp-admin/includes/schema.php )
#3 /wp-admin/upgrade.php (23): require_once( /wp-admin/includes/upgrade.php )

Change History (7)

#1 @SergeyBiryukov
2 years ago

  • Component changed from General to Database
  • Description modified (diff)

#3 @SergeyBiryukov
2 years ago

  • Keywords reporter-feedback added

Hi @malthert, welcome to WordPress Trac! Thanks for the report.

I could not reproduce the issue so far.

  1. Are you using a database drop-in (a wp-content/db.php file) or any caching plugins?
  2. Does the notice still persist after the upgrade, or only appears during the upgrade?
  3. Has the blogmeta table been created in the database?

#4 @malthert
2 years ago

1) no
2) no, only happened once during the update
3) no it's not there (I am on a simple WP install, no multi-site)

#5 @malthert
4 weeks ago

  • Resolution set to worksforme
  • Status changed from new to closed

#6 @desrosj
3 weeks ago

  • Milestone Awaiting Review deleted

@malthert Just wanted to confirm that closing this ticket was intentional. If possible, sharing the source of the problem could help others that run into a similar issue.

#7 @malthert
3 weeks ago

Thanks, yes it was intentional. I never encountered the issue again. Since it's been quite a few versions in the meantime, I assume the issue has been fixed somehow.

Note: See TracTickets for help on using tickets.