WordPress.org

Make WordPress Core

Opened 6 months ago

Closed 6 months ago

Last modified 6 months ago

#47993 closed defect (bug) (invalid)

5.2.3 revisions display incorrect user

Reported by: xxxLesy Owned by:
Milestone: Priority: normal
Severity: normal Version: 5.3
Component: Revisions Keywords:
Focuses: Cc:

Description

As of 5.2.3. revisions record incorrect user making post changes - always the original post author. Autosave records the correct user though. As does the "last edited by" on the all posts list. That is the case both in Classic and Guttenberg.

See attached screenshot.

Steps to reproduce:

  1. Write a post with a contributor account and submit to review.
  2. Open the post with an editor or admin account, make changes and save, plan or publish. All changes will be incorrectly shown as made by the original author.
  1. S. I do have a lot of plugins, so it is possible some effect this, though none of them are suppose to interact with revisions. So please try to reproduce on clean install. If that is the case, I apologize.

Attachments (2)

Opomba 2019-09-06 175721.png (111.3 KB) - added by xxxLesy 6 months ago.
Incorrect revision author screenshot
2019-09-06.png (14.8 KB) - added by tobifjellner 6 months ago.

Download all attachments as: .zip

Change History (6)

@xxxLesy
6 months ago

Incorrect revision author screenshot

#1 @tobifjellner
6 months ago

I tried on a relatively empty test site of mine. For me WP 5.2.3 behaves correctly. See image.

#2 @xxxLesy
6 months ago

  • Keywords close added
  • Resolution set to invalid
  • Status changed from new to closed

Thank you for checking. I did more testing based on your input. Turns out it was Molongui Authorship (multi author plugin). Will report there.

This ticket may be closed.

#3 @SergeyBiryukov
6 months ago

  • Keywords close removed
  • Milestone Awaiting Review deleted

#4 @SergeyBiryukov
6 months ago

Thanks for the follow-up!

Note: See TracTickets for help on using tickets.