WordPress.org

Make WordPress Core

#48019 closed defect (bug) (invalid)

A bug causing WP_Hook problems ?

Reported by: futureextreme Owned by:
Milestone: Priority: normal
Severity: normal Version: 5.2.3
Component: General Keywords: close
Focuses: Cc:

Description (last modified by SergeyBiryukov)

Bug Preview in Elementor in Word Press:

Fatal error: Uncaught Error: Class 'Elementor\Post_CSS_File' not found in /home1/futureex/public_html/futureextreme/wp-content/plugins/jet-theme-core/includes/locations.php:104
Stack trace:
#0 /home1/futureex/public_html/futureextreme/wp-includes/class-wp-hook.php(286): Jet_Theme_Core_Locations->enqueue_styles('')
#1 /home1/futureex/public_html/futureextreme/wp-includes/class-wp-hook.php(310): WP_Hook->apply_filters(NULL, Array)
#2 /home1/futureex/public_html/futureextreme/wp-includes/plugin.php(465): WP_Hook->do_action(Array)
#3 /home1/futureex/public_html/futureextreme/wp-includes/script-loader.php(2539): do_action('wp_enqueue_scri...')
#4 /home1/futureex/public_html/futureextreme/wp-includes/class-wp-hook.php(286): wp_enqueue_scripts('')
#5 /home1/futureex/public_html/futureextreme/wp-includes/class-wp-hook.php(310): WP_Hook->apply_filters(NULL, Array)
#6 /home1/futureex/public_html/futureextreme/wp-includes/plugin.php(465): WP_Hook->do_action(Array)
#7 /home1/futureex/public_html/futureextreme/wp-includes/general-temp in /home1/futureex/public_html/futureextreme/wp-content/plugins/jet-theme-core/includes/locations.php on line 104

Uncaught Error: Class 'Elementor\Post_CSS_File' not found in /home1/futureex/public_html/futureextreme/wp-content/plugins/jet-theme-core/includes/locations.php:104
Stack trace:
#0 /home1/futureex/public_html/futureextreme/wp-includes/class-wp-hook.php(286): Jet_Theme_Core_Locations->enqueue_styles('')
#1 /home1/futureex/public_html/futureextreme/wp-includes/class-wp-hook.php(310): WP_Hook->apply_filters(NULL, Array)
#2 /home1/futureex/public_html/futureextreme/wp-includes/plugin.php(465): WP_Hook->do_action(Array)
#3 /home1/futureex/public_html/futureextreme/wp-includes/script-loader.php(2539): do_action('wp_enqueue_scri...')
#4 /home1/futureex/public_html/futureextreme/wp-includes/class-wp-hook.php(286): wp_enqueue_scripts('')
#5 /home1/futureex/public_html/futureextreme/wp-includes/class-wp-hook.php(310): WP_Hook->apply_filters(NULL, Array)
#6 /home1/futureex/public_html/futureextreme/wp-includes/plugin.php(465): WP_Hook->do_action(Array)
#7 /home1/futureex/public_html/futureextreme/wp-includes/general-temp

My website shows as a white page with this error message. Everything is up to date.

Change History (6)

#1 follow-up: @davidbaumwald
11 months ago

  • Keywords 2nd-opinion removed
  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed

@futureextreme Welcome to Trac! Unfortunately, the issue you're having is with a third-party plugin, not WordPress Core. Try searching for your issue at https://wordpress.org/support/plugin/elementor/

#2 @SergeyBiryukov
11 months ago

  • Description modified (diff)

#3 in reply to: ↑ 1 ; follow-up: @futureextreme
11 months ago

Just to clarify. So this third party plugin causes my whole website to go down? The only thing showing is a page with the error message.

Replying to davidbaumwald:

@futureextreme Welcome to Trac! Unfortunately, the issue you're having is with a third-party plugin, not WordPress Core. Try searching for your issue at https://wordpress.org/support/plugin/elementor/

#4 in reply to: ↑ 3 @futureextreme
11 months ago

  • Resolution invalid deleted
  • Status changed from closed to reopened

Deactivated all plugins. Activating JetThemeCore triggers the error.

Replying to futureextreme:

Just to clarify. So this third party plugin causes my whole website to go down? The only thing showing is a page with the error message.

Replying to davidbaumwald:

@futureextreme Welcome to Trac! Unfortunately, the issue you're having is with a third-party plugin, not WordPress Core. Try searching for your issue at https://wordpress.org/support/plugin/elementor/

#5 @donmhico
11 months ago

  • Keywords close added

Hello @futureextreme,

Deactivated all plugins. Activating JetThemeCore triggers the error.

This confirms that the issue is with JetThemeCore's plugin. Unfortunately it is outside of what WordPress Trac is for. I strongly suggest you contact their support. I'll be marking this ticket as close.

#6 @davidbaumwald
11 months ago

  • Resolution set to invalid
  • Status changed from reopened to closed
Note: See TracTickets for help on using tickets.