WordPress.org

Make WordPress Core

Opened 23 months ago

Closed 11 days ago

#48045 closed defect (bug) (worksforme)

Save continually blinks, breaks if on bad wifi.

Reported by: programmin Owned by:
Milestone: Priority: normal
Severity: normal Version: 5.2.3
Component: Editor Keywords: reporter-feedback
Focuses: ui, accessibility, javascript, administration Cc:

Description

If you save draft while internet is disconnected or flaky, it just continues blinking the saving, and will now allow publishing or actually saving draft again when network is working again.

Steps to reproduce -

  • Save draft in Gutenberg editor with flaky internet connection.
  • Connect, reopen laptop when on good wifi.
  • Note that there is no way to save the post now.

Firefox console shows -
Yoast SEO and readability analysis: An error occurred during the building of the tree structure used for some assessments.

TypeError: e.children is undefined 65 analysis-1200.min.js:21:80480
TypeError: NetworkError when attempting to fetch resource.
uncaught exception: Object

There is now no way to save, I must go and read the current draft and go copy-paste all the blocks. Frustrating.

Change History (8)

This ticket was mentioned in Slack in #accessibility by afercia. View the logs.


21 months ago

This ticket was mentioned in Slack in #accessibility by afercia. View the logs.


17 months ago

#3 @afercia
17 months ago

@youknowriad when you have a chance :) Does this still happen after the introduction of the "sessionStorage autosave mechanism" in the block editor?

#4 @youknowriad
17 months ago

I've never seen this issue personally but worth moving this ticket to a Gutenberg issue for better investigations.

This ticket was mentioned in Slack in #accessibility by alexstine. View the logs.


4 months ago

This ticket was mentioned in Slack in #accessibility by joedolson. View the logs.


2 weeks ago

#7 @joedolson
2 weeks ago

  • Keywords reporter-feedback added

@youknowriad Was this ever moved to Github for further investigation? Do you think it's still a problem at this point?

@programmin Have you continued to experience this problem with later versions of the block editor?

#8 @youknowriad
11 days ago

  • Milestone Awaiting Review deleted
  • Resolution set to worksforme
  • Status changed from new to closed

Thanks for the ping here,

I think this is probably not an issue anymore, the UI has changed since then and I'm not personally able to reproduce any issue.

If you still experience it, please consider opening a GitHub issue here https://github.com/WordPress/gutenberg/issues/new/choose

Note: See TracTickets for help on using tickets.