Make WordPress Core

Opened 4 years ago

Closed 4 years ago

#48081 closed enhancement (fixed)

Require PHP >= 5.6 in composer.json

Reported by: ayeshrajans's profile ayeshrajans Owned by: desrosj's profile desrosj
Milestone: 5.3 Priority: normal
Severity: trivial Version:
Component: Build/Test Tools Keywords: has-patch commit
Focuses: docs, coding-standards Cc:


Now that we are requiring PHP 5.6, perhaps we can indicate this in the composer.json file bundled?

Attached patch updates the composer.json file and also includes the lock file update with composer update --lock.

Thank you.

Attachments (1)

48081-1.patch (1.0 KB) - added by ayeshrajans 4 years ago.

Download all attachments as: .zip

Change History (5)

4 years ago

#1 @jrf
4 years ago


#2 @netweb
4 years ago

  • Keywords commit added
  • Milestone changed from Awaiting Review to 5.3

#3 @desrosj
4 years ago

  • Owner set to desrosj
  • Status changed from new to reviewing

#4 @desrosj
4 years ago

  • Resolution set to fixed
  • Status changed from reviewing to closed

In 46200:

Build/Test Tools: Specify PHP 5.6 as the required version of PHP in Composer.

Props ayeshrajans, jrf, netweb.
Fixes #48081.

Note: See TracTickets for help on using tickets.