WordPress.org

Make WordPress Core

Opened 3 months ago

Closed 2 months ago

Last modified 2 months ago

#48090 closed enhancement (fixed)

Provide simple debug data in WSOD emails

Reported by: Clorith Owned by: SergeyBiryukov
Milestone: 5.3 Priority: normal
Severity: normal Version: 5.2
Component: Site Health Keywords: has-patch commit
Focuses: Cc:
PR Number:

Description

Errors are terrible, if you're not familiar with troubleshooting, they're even worse.

What happens if you get the dreaded email from WordPress, your site has crashed, you know something broke, but are lost beyond that, so you go to seek help in fixing it. Unfortunately you can't help others, help you. They asked you something simple; what version of the Plugin X are you using? You have no idea, you feel lost, those helping you feel frustration, it's bad times all around.

But wait, there, in the distance, a shimmering light!

When an error email is sent, let's include a new section, prefix it with When seeking help with this issue, you may be asked for some of the following information, and then add the current WP version, the plugin version of that which broke, what theme is in use would also be handy, this is all information we can readily grab and provide after all!

Attachments (2)

48090.patch (4.8 KB) - added by Clorith 3 months ago.
48090.2.patch (5.0 KB) - added by Clorith 2 months ago.

Download all attachments as: .zip

Change History (9)

@Clorith
3 months ago

#1 @Clorith
3 months ago

  • Keywords has-patch commit added
  • Version set to 5.2

48090.patch expands the email sent with the most commonly asked questions when something crashes, namely the WordPress version, what theme is being used, and the version of the plugin that caused an issue (if caused by a plugin).

These are all created as an associated array, which is filterable through recovery_email_debug_info, making it possible to add more details in some scenarios.

The information sent is intentionally constricted on our end, to avoid information overload and confusion for the end user.

The patch also moves the code for fetching plugin details out of the get_cause() function to a separate get_plugin() call so that it can be reused more easily when building the error email.

#2 @TimothyBlynJacobs
3 months ago

This would be awesome. I think adding the PHP version would be highly valuable here as well.

@Clorith
2 months ago

#3 @Clorith
2 months ago

Sounds reasonable as a likely cause of a failure, 48090.2.patch includes this.

#4 @davidbaumwald
2 months ago

  • Milestone changed from 5.3 to 5.4

With version 5.3 Beta 1 landing today, this is being moved into 5.4 based on recent momentum.

#5 @SergeyBiryukov
2 months ago

  • Owner set to SergeyBiryukov
  • Resolution set to fixed
  • Status changed from new to closed

In 46273:

Site Health: Include simple debug data in fatal error protection email.

Introduce recovery_email_debug_info filter for the debug information included in the email.

Props Clorith, TimothyBlynJacobs.
Fixes #48090.

#6 @Clorith
2 months ago

  • Milestone changed from 5.4 to 5.3

This ticket was mentioned in Slack in #core-site-health by garrett-eclipse. View the logs.


2 months ago

Note: See TracTickets for help on using tickets.