WordPress.org

Make WordPress Core

Opened 4 months ago

Closed 2 months ago

#48102 closed feature request (wontfix)

Appearance > Menus: Allow adding custom post type archives with no posts

Reported by: danburzo Owned by:
Milestone: Priority: normal
Severity: minor Version: 5.2.3
Component: Menus Keywords:
Focuses: administration Cc:
PR Number:

Description

You should be able to add a custom post type archive to a Menu even if there are no posts of that type available. Right now, the sidebar shows No items, with no option of linking to the archive.

This is more of a nuisance: you can create a dummy post, link to the archive, then remove the post.

Change History (1)

#1 @welcher
2 months ago

  • Focuses administration added
  • Milestone Awaiting Review deleted
  • Resolution set to wontfix
  • Status changed from new to closed
  • Type changed from defect (bug) to feature request

@danburzo thank you for the ticket!

This is by design as the Posts archive is also not available if there are no posts in the database. Any post type archive can be added to a menu by using a Custom Link and I'm not sure there is enough of a use-case here to add this feature into WordPress core.

Note: See TracTickets for help on using tickets.