WordPress.org

Make WordPress Core

Opened 17 months ago

Closed 2 months ago

#48197 closed feature request (duplicate)

Add support for assigning multiple domains to a single site in multisite

Reported by: juanfry Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Networks and Sites Keywords:
Focuses: multisite Cc:

Description

Hello,

We are using the [native domain mapping|https://wordpress.org/support/article/wordpress-multisite-domain-mapping/] from WordPress in our latest sites and it works like a charm.

I would like to request if a multidomain mapping could be done in core WordPress. We have several clients with more than one domain pointing to the same website.

Kind regards,

Juanfran Granados

Change History (6)

#1 @knutsp
17 months ago

  • Component changed from Administration to Networks and Sites
  • Keywords 2nd-opinion reporter-feedback added
  • Summary changed from Hello, We are using the native domain mappinghttps://wordpress.org/support/article/wordpress-multisite-domain-mapping/ to Hello, We are using the native domain mapping https://wordpress.org/support/article/wordpress-multisite-domain-mapping/

Hello, @juanfry and very welcome to Trac!

Thank you for the suggestion!

My question will be, since you say the plugin "works like a charm", you want it in core?

Since Multisite does not need Domain Mapping to handle different domains on each site, and since www-forwarding is a common and free service on domain registrars, the need to let more than one domain point to the same site quite an edge case. Such functionality is usually best served a plugin, IMO.

I used Domain Mapping until eight years ago, but ripped it out once WordPress Multisite became more flexible and easy to configure on different domains, extracting the mapping of more than one domain to same site as to a simple forwarder outside WP. Yet, I acknowledge that such forwarders only work with http, not https.

Still, this may be a good idea, since it's a simple thing to do, at least if it can be done without extra tables.

#2 @earnjam
17 months ago

  • Keywords close added
  • Summary changed from Hello, We are using the native domain mapping https://wordpress.org/support/article/wordpress-multisite-domain-mapping/ to Add support for assigning multiple domains to a single site in multisite

In general domain redirects can be handled using web server level directives (.htaccess, etc), or the sunrise.php file. There are also some domain mapping type plugins that can handle multiple domain assignments like this, such as Mercator and WP Site Aliases.

I personally would lean toward this functionality remaining external, but I'll defer to the Network & Sites component maintainers.

#3 @juanfry
17 months ago

Thanks, for the replies.

@knutsp, @earnjam, yes, what I would like to know is if that feature makes sense in the core.

This ticket was mentioned in Slack in #core-multisite by richardtape. View the logs.


10 months ago

#5 @hellofromTonya
2 months ago

  • Keywords reporter-feedback removed

@juanfry is asking if this is this enhancement makes sense for core. What you think?

Pinging the component maintainers @jeremyfelt @flixos90 @johnjamesjacoby @spacedmonkey to get their opinions.

#6 @jeremyfelt
2 months ago

  • Keywords 2nd-opinion close removed
  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #27783.

Thanks for the ticket, @juanfry!

I don't believe domain mapping is something that needs to be included in core. As mentioned in the ticket description and the comments, there are plugins that handle common use cases and plenty of custom code that handles the variety of other use cases. We have had other discussions (chat, in person, likely in tickets) to better determine the scope that a core version of domain mapping would need to cover. In the end it's something that just isn't done too frequently as a total percentage of users and it's easier to justify spending time improving existing features. (Heavily my opinion, feel free to ignore me!)

In the past, domain mapping has also been confused with the use of arbitrary domains and paths. While core itself does support these, there is still plenty of room for improvement in the UI for creating/editing sites. I've often thought that really solving this problem would eliminate many sites' need for the domain mapping plugins. See previously: #22383 and #31240.

I'm going to go ahead and close this out as a duplicate of #22783, as the request matches pretty closely.

Note: See TracTickets for help on using tickets.