WordPress.org

Make WordPress Core

Opened 8 months ago

Closed 8 months ago

#48208 closed defect (bug) (worksforme)

Page freezes when trying to delete media

Reported by: clem5on Owned by:
Milestone: Priority: normal
Severity: normal Version: 5.2.3
Component: Media Keywords: reporter-feedback
Focuses: Cc:

Description

After latest update, anytime "delete permanently" is clicked in media (I've been attempting to delete two image files), site freezes (pinwheel on Mac) and have to refresh page. Edit functions fine, upload is fine as well.

Deactivated recently installed plugins and none were the culprit. Host is WPEngine and did an update to latest WordPress within the last two hours (noticed the issue after).

Change History (4)

#1 @clem5on
8 months ago

[edit] also tried selecting multiple images just now, bulk deleting. Page freezes on "apply". The button starts presses down but won't execute and freeze ensues.

#2 @adamsilverstein
8 months ago

  • Keywords reporter-feedback added; needs-patch removed

Hi @clem5on - thanks for the bug report.

I attempted to reproduce this issue (on trunk) and was unable to. Is the issue specific to the images you are trying to delete? Do other images delete correctly if you upload a new image for example?

Here is what I tried:

  • Open the media library and upload several images
  • Select an image and click delete permanently, confirming in dialog
  • Click "Edit Image" and then "Delete Permanently"

In both cases, the image deleted correctly without any errors or freezing issues.

Can you please try temporarily disabling all plugins, retest, and if still not fixed, try using a default WordPress theme as well (I tested with the new twentytwenty theme active)? Does this resolve the issue?

Do you see any errors in your browsers debug console? (instructions to open in chrome - https://developers.google.com/web/tools/chrome-devtools/open)

#3 @clem5on
8 months ago

Hey Adam, so oddly enough it resolved itself. I contacted my server host to ask if they had heard anything about this (since I do auto-updates from my panel there). They hadn't, and while remote editing my media library it worked fine for them. I did a Mac restart and the issue was gone. Hopefully if someone else finds this issue they too will do the old restart to fix haha.

#4 @adamsilverstein
8 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to worksforme
  • Status changed from new to closed

Thanks for confirming @clem5on - closing as 'worksforme'

Note: See TracTickets for help on using tickets.