WordPress.org

Make WordPress Core

Opened 7 weeks ago

Closed 5 weeks ago

Last modified 5 weeks ago

#48232 closed task (blessed) (fixed)

Remove PHP7.4 from allowed failures

Reported by: jorbin Owned by: jorbin
Milestone: 5.3 Priority: normal
Severity: normal Version:
Component: Build/Test Tools Keywords:
Focuses: Cc:
PR Number:

Description

WordPress 5.3 should support PHP7.4 fully and completely.

Change History (5)

#1 @jorbin
7 weeks ago

  • Owner set to jorbin
  • Status changed from new to assigned

#2 follow-up: @jrf
6 weeks ago

Note: as of this weekend, Travis still does not provide an officially supported PHP 7.4 image for builds.
The image currently being used is an unofficial one.

Version 0, edited 6 weeks ago by jrf (next)

#3 in reply to: ↑ 2 @jorbin
6 weeks ago

Replying to jrf:

Note: as of this weekend, Travis still does not provide an officially supported PHP 7.4 image for builds.
The image currently being used is an unofficial one.

The tests are run in the wpdev-docker-images, not the travis images. These inherit from the official docker php images.

#4 @jorbin
5 weeks ago

  • Resolution set to fixed
  • Status changed from assigned to closed

In 46547:

Build/Test: Remove PHP 7.4 from allowed failures

PHP7.4 is supported in WordPress 5.3. :elephant: :tada:

Fixes: #48232.

#5 @SergeyBiryukov
5 weeks ago

In 46552:

Build/Test Tools: Move PHP 7.4 to the top of the list for consistency.

See #48232.

Note: See TracTickets for help on using tickets.