WordPress.org

Make WordPress Core

Opened 5 months ago

Last modified 6 weeks ago

#48268 new defect (bug)

Updating failed. Error message: The response is not a valid JSON response.

Reported by: phpdocs Owned by:
Milestone: Awaiting Review Priority: normal
Severity: critical Version:
Component: Posts, Post Types Keywords: reporter-feedback
Focuses: Cc:

Description

Hi,

When i try to update the Page Template from default to full page then i am getting that error "Updating failed. Error message: The response is not a valid JSON response." in WordPress Version 5.3

Attachments (1)

Screen Shot 2019-10-10 at 10.26.21 AM.png (954.0 KB) - added by phpdocs 5 months ago.
Error screen shot

Download all attachments as: .zip

Change History (9)

@phpdocs
5 months ago

Error screen shot

#1 @SergeyBiryukov
5 months ago

  • Keywords reporter-feedback added

Hi @phpdocs, welcome to WordPress Trac! Thanks for the report.

Does the issue still happen with all plugins disabled and a default theme (Twenty Nineteen) activated?

#2 @phpdocs
5 months ago

Hi @SergeyBiryukov, yes same issue with Twenty Nineteen and all plugins are disabled.

#3 @phpdocs
5 months ago

@SergeyBiryukov recently i checked same issue with posts.

#4 @diquispe
4 months ago

Same BUG with my site with elementor, disabled themes and plugins with the same error

#5 @ncpr
4 months ago

Seeing same on one of our 5.3 installations using Twenty Nineteen. Happens when editing posts or pages, in any field as far as we can tell, but Quick Edit works for some things just fine.

#6 @nicolebernd
7 weeks ago

I wanted to provide some info.

I just experienced the same issue after using Elementor and trying to remove it in favor of a more lightweight option. When I disabled Elementor I got the error shown here. When I enabled it again I was able to at least save the draft but I cannot publish the post. I was trying to save a custom post type made with Metabox.io

I am using WordPress 5.3+ as well as the latest version of Elementor.

Version 1, edited 7 weeks ago by nicolebernd (previous) (next) (diff)

#7 follow-up: @stidch
6 weeks ago

I don't know if the issue I face is exactly the same, but at least looks similar.

I cannot save any page, which contain a shortcode, which contain a call to a java-script method

For example:

onload="resizeIframe(this)"

In my case I try to resize an iframe with the advanced-iframe plugin. The full shortcode looks like this:

advanced_iframe src="https://xxx.com/script.php?parameter=value" frameborder="0" scrolling="no" onload="resizeIframe(this)"

In an html block above I'v defined the resizeIframe method.

<script>
function resizeIframe(iframe) {
  iframe.height = "10px" // required for reducing the size
  iframe.height = iframe.contentWindow.document.body.scrollHeight + "px";
}
</script>

If I remove the part

onload="resizeIframe(this)

from the shortcode I can successfully save the page. With I can't.

I've tried already with disabled plugins and default theme.

#8 in reply to: ↑ 7 @stidch
6 weeks ago

Just found out that my issue is most probably the one which is filed here:
https://core.trac.wordpress.org/ticket/48698

Last edited 6 weeks ago by stidch (previous) (diff)
Note: See TracTickets for help on using tickets.