WordPress.org

Make WordPress Core

Opened 5 weeks ago

Closed 3 weeks ago

#48274 closed defect (bug) (reported-upstream)

WordPress beta 5.3 - Meta Checkbox - SVG Blue color

Reported by: veminom Owned by:
Milestone: Priority: normal
Severity: normal Version: 5.3
Component: Editor Keywords:
Focuses: ui, accessibility, administration Cc:
PR Number:

Description

After testing WordPress 5.3 Beta I found that WordPress is adding SVG of blue color as a check inside checkbox with a blue background.

Please see the screenshot below:
https://cl.ly/ed08072faae6

This is making the check color similar to the background color and hence it is not appearing properly.

SVG - data:image/svg+xml;utf8,%3Csvg%20xmlns%3D%27http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg%27%20viewBox%3D%270%200%2020%2020%27%3E%3Cpath%20d%3D%27M14.83%204.89l1.34.94-5.81%208.38H9.02L5.78%209.67l1.34-1.25%202.57%202.4z%27%20fill%3D%27%231e8cbe%27%2F%3E%3C%2Fsvg%3E

Screenshot - https://cl.ly/b308427ca18f

In my opinion it should be white. Keeping this white will make it appear properly as a check with blue background in Meta Checkbox.

Just for the refrence, old checkbox use to look like this - https://cl.ly/ace03fc10235

Change History (10)

#1 @SergeyBiryukov
5 weeks ago

  • Component changed from General to Editor
  • Focuses administration added

#2 follow-up: @SergeyBiryukov
5 weeks ago

  • Keywords reporter-feedback added

Hi @veminom, welcome to WordPress Trac! Thanks for the report.

Does the issue still happen with all plugins disabled and a default theme (Twenty Nineteen) activated?

#3 in reply to: ↑ 2 @veminom
4 weeks ago

Hi @SergeyBiryukov,

This issue happens with all the plugins disabled. Unfortunately, there are no custom meta checkboxes in the default themes, so I was unable to reproduce this issue with any of the WordPress default themes.

While I was able to reproduce this issue with popular themes like GeneratePress, Astra, Neve.

Replying to SergeyBiryukov:

Hi @veminom, welcome to WordPress Trac! Thanks for the report.

Does the issue still happen with all plugins disabled and a default theme (Twenty Nineteen) activated?

This ticket was mentioned in Slack in #core by veminom. View the logs.


4 weeks ago

#5 @audrasjb
4 weeks ago

  • Keywords needs-patch reporter-feedback removed
  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Severity changed from major to normal
  • Status changed from new to closed
  • Version trunk deleted

Hi and thanks for the ticket, @veminom !

Like #48275, looks like Astra theme author is overriding Gutenberg Admin CSS.
They should update their custom CSS for WP 5.3.

In General, it's not very safe to override existing CSS in WP-Admin as that CSS is supposed to evolve.

Further informations available on the following Make/Core Developer Note:
https://make.wordpress.org/core/2019/10/18/noteworthy-admin-css-changes-in-wordpress-5-3/

#6 @veminom
4 weeks ago

Hello @audrasjb

Thank you for looking into this.

Yes, you are correct, #48275 seems to be coming from Theme only.

But this one seems to be coming from WordPress only with

background: #11a0d2;

Can you please check?

Screenshot: https://cl.ly/010074a7efe9

#7 @SergeyBiryukov
3 weeks ago

  • Milestone set to Awaiting Review
  • Resolution invalid deleted
  • Status changed from closed to reopened
  • Version set to trunk

Reopening to investigate comment:6.

#8 @audrasjb
3 weeks ago

  • Focuses accessibility added
  • Keywords 2nd-opinion close added
  • Milestone changed from Awaiting Review to 5.3

Hey,

I think the issue has to be fixed on Gutenberg GitHub repository.
I reported it upstream: https://github.com/WordPress/gutenberg/issues/18053

Let's keep it open while we wait for the bloc editor team answer.

Cheers,
Jb

This ticket was mentioned in Slack in #core by audrasjb. View the logs.


3 weeks ago

#10 @davidbaumwald
3 weeks ago

  • Keywords 2nd-opinion close removed
  • Milestone 5.3 deleted
  • Resolution set to reported-upstream
  • Status changed from reopened to closed

Closing as reported-upstream with https://github.com/WordPress/gutenberg/issues/18053

Note: See TracTickets for help on using tickets.