WordPress.org

Make WordPress Core

Opened 9 months ago

Closed 9 months ago

Last modified 9 months ago

#48275 closed defect (bug) (invalid)

WordPress beta 5.3 - Meta Select Box - Width issue

Reported by: veminom Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Editor Keywords:
Focuses: ui, administration Cc:

Description

After testing WordPress 5.3 Beta I found that Meta Select boxes are going out of the visible area from the right.

Screenshot: https://cl.ly/da2bb8b87a30

It should appear inside the sidebar.

Just for the reference, earlier it used to appear like this - https://cl.ly/c0ad6bb2db27

Attachments (1)

Capture d’écran 2019-10-21 à 12.51.00.png (34.4 KB) - added by audrasjb 9 months ago.
Removing override code.

Download all attachments as: .zip

Change History (7)

#1 @SergeyBiryukov
9 months ago

  • Component changed from General to Editor
  • Focuses administration added

#2 follow-up: @SergeyBiryukov
9 months ago

  • Keywords reporter-feedback added

Hi @veminom, welcome to WordPress Trac! Thanks for the report.

Does the issue still happen with all plugins disabled and a default theme (Twenty Nineteen) activated?

#3 in reply to: ↑ 2 @veminom
9 months ago

Hi @SergeyBiryukov,

This issue happens with all the plugins disabled. Unfortunately, there is no custom meta select box in the default themes, so I was unable to reproduce this issue with any of the WordPress default themes.

While I was able to reproduce this issue with popular theme Astra.

Replying to SergeyBiryukov:

Hi @veminom, welcome to WordPress Trac! Thanks for the report.

Does the issue still happen with all plugins disabled and a default theme (Twenty Nineteen) activated?

This ticket was mentioned in Slack in #core by veminom. View the logs.


9 months ago

@audrasjb
9 months ago

Removing override code.

#5 @audrasjb
9 months ago

  • Keywords needs-patch reporter-feedback removed
  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Severity changed from major to normal
  • Status changed from new to closed
  • Version trunk deleted

Thanks for the ticket @veminom !

Looks like Astra theme author is overriding Gutenberg Admin CSS.
They will have to remove the min-width CSS declaration (see screenshot above).
In General, it's not very safe to override existing CSS in WP-Admin as that CSS is supposed to evolve.

Further informations available on the following Make/Core Developer Note:
https://make.wordpress.org/core/2019/10/18/noteworthy-admin-css-changes-in-wordpress-5-3/

#6 @veminom
9 months ago

@audrasjb Thank you for the response, this really looks like the issue is from theme only. We will definitely add a fix for this.

Thank you for looking into this.

But in ticket #48274, it looks like the background color is actually coming from the WP?

https://cl.ly/010074a7efe9

Though this ticket can be closed.

Note: See TracTickets for help on using tickets.