WordPress.org

Make WordPress Core

Opened 6 months ago

Closed 6 months ago

Last modified 5 months ago

#48338 closed defect (bug) (fixed)

Twenty Twenty background image setting

Reported by: afercia Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Bundled Theme Keywords: has-screenshots has-patch
Focuses: ui Cc:

Description

Not sure if this was already discussed and considered. Thought to report it anyways as the current behavior doesn't seem ideal to me.

Twenty Twenty declares support for custom background.

However, it handles only custom colors and doesn't provide a UI in the Customizer to handle background images.

This leads to an inconsistency in the WordPress admin UI: in the admin menu, a "Background" link is displayed:

http://cldup.com/tfmXSeSu02.jpg

Clicking this link opens the Customizer but it doesn't do anything else. The customizer opens and displays its main panel in the sidebar.

Instead, the expected behavior is that it opens the Customizer and then it switches the left panel to the "Background" one. You can check what the expected behavior is by using another bundled theme that supports a background image, e.g. Twenty Sixteen:

  • click on the "Background" link in the admin menu
  • the Customizer opens
  • after a brief delay, the "Background" panel appears sliding in from the right

Instead, with Twenty Twenty active, the Background link doesn't do what users would expect. It just opens the Customizer and... well where's the background setting?

Moreover:
it's still possible to access the legacy background page at wp-admin/themes.php?page=custom-background if users know the URL or if they bookmarked it. In this page I can set a background image for Twenty Twenty :)

After that, the Customizer displays the background image:

http://cldup.com/UzTZYYl0ZH.jpg

But then again, the Customizer doesn't provide any UI to manage the background image.

Attachments (1)

48338.diff (844 bytes) - added by mukesh27 6 months ago.
Patch that enable custom background support.

Download all attachments as: .zip

Change History (12)

#1 @kebbet
6 months ago

I noticed the same thing, and created a ticket for it in the Github repo, where the theme is developed.
https://github.com/WordPress/twentytwenty/issues/858

And a Core issue for the underlaying problem.. #48330

Last edited 6 months ago by SergeyBiryukov (previous) (diff)

#2 @afercia
6 months ago

@kebbet thanks! Yup I now see it's intentional in Twenty Twenty:

https://core.trac.wordpress.org/browser/trunk/src/wp-content/themes/twentytwenty/classes/class-twentytwenty-customize.php?rev=46551&marks=29-33#L28

$wp_customize->remove_section( 'background_image' );

However, this leads to a user experience that's not ideal, IMHO.

Also, at this point of the release (we're in Release Candidate) development should really happen on Trac / SVN and not on GitHub as any change must be reviewed and "signed off" by two core committers.

#3 @afercia
6 months ago

  • Keywords needs-patch added
  • Milestone changed from Awaiting Review to 5.3

@mukesh27
6 months ago

Patch that enable custom background support.

#4 @mukesh27
6 months ago

  • Keywords has-patch added; needs-patch removed

#5 @ocean90
6 months ago

  • Milestone 5.3 deleted
  • Resolution set to reported-upstream
  • Status changed from new to closed
  • Version trunk deleted

Closing as reported upstream.

Development still happens on GitHub. If there's something to import we'll reopen #48110 again to review and sign-off any patches.

#6 @afercia
6 months ago

For future releases I'd propose to discuss when a bundled theme development should be moved to Trac / SVN. To me, from the moment a bundled theme gets merged in core, development should happen in core.

Also: @ocean90 if you're closing tickets because "reported upstream" it would be greatly appreciated if you could add the details reported here to the "upstream" issue.

#7 @desrosj
6 months ago

#48330 was marked as a duplicate.

#8 @poena
5 months ago

The removal of the setting was reverted in the theme itself.

That the background image and background color are set together in the same theme support is still an issue.

#9 @afercia
5 months ago

@poena thanks for the update! Shall we close this ticket then and create a new one to explore splitting custom background support in two separate pieces as mentioned in https://github.com/WordPress/twentytwenty/issues/858#issuecomment-543568847 ?

#11 @afercia
5 months ago

  • Resolution changed from reported-upstream to fixed

Cool, thanks! Closing as fixed "upstream" (whatever that means, as this is in core).

Note: See TracTickets for help on using tickets.