WordPress.org

Make WordPress Core

Opened 4 weeks ago

Closed 4 weeks ago

#48398 closed defect (bug) (duplicate)

WordPress UPLOAD+ACTIVATE fails if more than one plugin in plugin's folder

Reported by: KestutisIT Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Plugins Keywords:
Focuses: Cc:
PR Number:

Description

So,
As I developed a plugin that support multiple extensions, I have in plugin folder two files, i.e.

/GreatPlugin/ExtensionA.php (with "Plugin Name: Extension A" in header)
/GreatPlugin/ExtensionB.php (with "Plugin Name: Extension B" in header)

So if I upload plugin manually, I activate the one I want.
But if I upload via "Upload ZIP" and after extraction I see "activate" button, it somewhy without any clear reason activates the first one.

In the correct scenario, it should:

  1. Either show me a list on that POST-UPLOAD-AND-EXTRACT screen which exact plugin to activate.
  2. Or it would have to activate ALL plugins in the plugin folder.

NOTE (if someone has a question why the hell you may ever need to have two plugin activations in same plugin folder), the answer is:

  1. No code duplication (same /<PLUGIN_FOLDER>/Models/, /<PLUGIN_FOLDER>/Controllers/ and /<PLUGIN_FOLDER>/Views/ content, only the /UI/ folder content is different per extension).
  2. WordPress does allows me to do that - and there is no logical restriction why it should not allow to do that - as in MVC & Libraries world the 'extensions' are very common solution to not to have so-called 'dependency hell' - different library version in different plugin folder, while it is actually same plugin just with different extensions).

Change History (1)

#1 @ocean90
4 weeks ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Severity changed from major to normal
  • Status changed from new to closed
  • Version 5.2.3 deleted

Duplicate of #22287.

Note: See TracTickets for help on using tickets.