WordPress.org

Make WordPress Core

#48412 closed defect (bug) (duplicate)

Remove the word ERROR from all error messages

Reported by: afercia Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Administration Keywords:
Focuses: ui, accessibility, ui-copy Cc:

Description

Follow up to ticket:43037#comment:42

On #43037, some error messages for the login screen were improved and, amongst other things, the all caps word ERROR was removed..

There are other occurrences in core of the all caps ERROR included in error messages, and sentence case Error as well.

I'd like to propose to remove all of them: all caps should be avoided for better readability and because screen readers may pronounce all caps words as abbreviations.

Also: sometimes ERROR is all caps, sometimes it's sentence case, sometimes it's bold, sometimes the entire error message is bold. The most recently added ones (PHP compatibility and SIte Health) seem to use sentence case. Some consistency would be nice.

A few examples:

<strong>ERROR:</strong> There was an error connecting to the server ...
<strong>Error:</strong> Current WordPress and PHP versions do not meet ...
<strong>Error:</strong> This plugin <strong>requires a newer version of PHP</strong>.
<strong>' . __( 'ERROR: The network could not be created.' ) . '</strong>

These messages appear in admin notices that are already marked as errors because of the red border. Moreover, I'm not sure there's the need to specify "error" at the beginning of the message, as that's not relevant for users. Instead, it's the content of the message that is relevant. For example:

ERROR: There was an error connecting to the server, Please verify the settings are correct.

Admittedly, this is the more evident case as the word "error" is repeated also in the second part of the message. (note: the comma should be changed to a period)

Also in other cases "Error" could be just removed. For example:

Error: Current WordPress and PHP versions do not meet minimum requirements for {plugin name here}

As a user, I'm not interested whether this is an error, a warning, an informational message or whatever :) I'm just interested in the content of the message which is already made prominent by the notice styling.

Change History (2)

#1 @garrett-eclipse
21 months ago

  • Focuses ui-copy added

Related: #47656

@afercia some context on the capitalization can be found on #47656 I agree it should be consistent. Am unsure if switching to capitalized means we lose the emphasis that all-caps provides there. Whatever the result would be nice to isolate from the strings to allow strings to be more re-usable.
*Was thinking of closing as duplicate but each ticket is flagging alternate issues/views.

#2 @afercia
21 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #47656.

Ah thanks @garrett-eclipse will close then and copy this ticket description over there.

Note: See TracTickets for help on using tickets.