WordPress.org

Make WordPress Core

Opened 3 weeks ago

Closed 7 days ago

#48448 closed defect (bug) (reported-upstream)

Audio in Twenty Sixteen are lacking bottom margin

Reported by: PGeorgiev Owned by:
Milestone: Priority: normal
Severity: normal Version: 5.3
Component: Editor Keywords: has-patch dev-feedback
Focuses: ui Cc:
PR Number:

Description

Posts that have audio: the comment link is too close to the media.

Attachments (3)

audio-no-margin-bottom.png (580.4 KB) - added by PGeorgiev 3 weeks ago.
Posts that have audio: the comment link is too close to the media.
firefox-audio-no-margin-bottom.png (596.3 KB) - added by PGeorgiev 3 weeks ago.
48448.diff (403 bytes) - added by PGeorgiev 3 weeks ago.

Download all attachments as: .zip

Change History (7)

@PGeorgiev
3 weeks ago

Posts that have audio: the comment link is too close to the media.

@PGeorgiev
3 weeks ago

#1 follow-up: @emilyatmobtown
2 weeks ago

  • Keywords dev-feedback added

Thank you for reporting this, @PGeorgiev!

I've confirmed that this bug exists. The Audio block lacks a bottom margin, unlike other blocks such as the quote block and image block. However, this exists across all themes, not just Twenty Sixteen.

I'd suggest adding the bottom margin to .wp-block-audio in the Gutenberg's CSS to be consistent with .wp-block-image and .wp-block-quote.

(Additionally, I'd suggest adding it to .wp-block-audio rather than .wp-block-audio audio so that the margin is added below the caption, if one exists.)

I've tagged this for dev feedback for further discussion about best implementation and will open an issue in the Gutenberg repo and paste the link below to cross-reference.

#2 @emilyatmobtown
2 weeks ago

A Github issue has been opened on the Gutenberg repo for further discussion: https://github.com/WordPress/gutenberg/issues/18255

#3 in reply to: ↑ 1 @PGeorgiev
12 days ago

Replying to emilyatmobtown:

Thank you for reporting this, @PGeorgiev!

I've confirmed that this bug exists. The Audio block lacks a bottom margin, unlike other blocks such as the quote block and image block. However, this exists across all themes, not just Twenty Sixteen.

I'd suggest adding the bottom margin to .wp-block-audio in the Gutenberg's CSS to be consistent with .wp-block-image and .wp-block-quote.

(Additionally, I'd suggest adding it to .wp-block-audio rather than .wp-block-audio audio so that the margin is added below the caption, if one exists.)

I've tagged this for dev feedback for further discussion about best implementation and will open an issue in the Gutenberg repo and paste the link below to cross-reference.

Hey @emilyatmobtown,
Thanks for your time and your response! I will add these changes and update the ticket.
Thank you!

#4 @SergeyBiryukov
7 days ago

  • Component changed from Bundled Theme to Editor
  • Milestone Awaiting Review deleted
  • Resolution set to reported-upstream
  • Status changed from new to closed

Hi there, welcome to WordPress Trac! Thanks for the ticket.

It looks like this is an issue with editor styles, rather than Twenty Sixteen. As the issue is now reported upstream for Gutenberg in https://github.com/WordPress/gutenberg/issues/18255, closing this one.

Note: See TracTickets for help on using tickets.