Make WordPress Core

Opened 17 years ago

Closed 15 years ago

Last modified 15 years ago

#4846 closed enhancement (duplicate)

"Unified permissions" mode for multiple WP installs sharing users/usermeta

Reported by: markjaquith's profile markjaquith Owned by: jacobsantos's profile jacobsantos
Milestone: Priority: normal
Severity: normal Version: 2.3
Component: General Keywords:
Focuses: Cc:

Description

It would be nice if there were a way for "slave" WP installs using the user/usermeta tables from a "master" WP install to use the master's roles/levels instead of having to set its own. Some people don't mind if roles are global across all blogs, and it would certainly make the feature easier to implement.

We should be able to do this by having the slave installs define something like: define('WP_PERMISSIONS_PREFIX', 'wp_master_'); in wp-config.php

Change History (8)

#1 @ryan
17 years ago

Simple enough. +1

#2 follow-up: @hovenko
17 years ago

This just seems as a hack to cover up another hack. A far better solution would be to create new tables for capabilities/roles to fix the design problem with WordPressMU.

-1

#3 in reply to: ↑ 2 @westi
17 years ago

Replying to hovenko:

This just seems as a hack to cover up another hack. A far better solution would be to create new tables for capabilities/roles to fix the design problem with WordPressMU.

-1

I don't see this as a hack at all. I don't really see what the design problems are?

  1. We have a set of users/roles/capabilities that apply to a single blog.
  2. You can tell another blog in the same database to share the user, roles and capabilites storage locations.
  3. You can give users different roles per blog.

The one thing that is missing is what this ticket describes - making all blogs sharing one set of users/roles/capabilities use the same role/capabilities settings for each user on every blog.

+1

#4 @JeremyVisser
17 years ago

Possibility to use separate databases too? (Pretty please?)

#5 @ffemtcj
16 years ago

  • Milestone changed from 2.5 to 2.6

#6 @santosj
16 years ago

  • Owner changed from anonymous to jacobsantos

#7 @DD32
15 years ago

  • Resolution set to duplicate
  • Status changed from new to closed

Closing as duplicate of #3444

#8 @jacobsantos
15 years ago

  • Milestone 2.9 deleted
Note: See TracTickets for help on using tickets.