WordPress.org

Make WordPress Core

Opened 5 weeks ago

Closed 4 weeks ago

#48466 closed defect (bug) (duplicate)

Block editor: radio buttons broken layout within the meta boxes area

Reported by: afercia Owned by: youknowriad
Milestone: Priority: normal
Severity: normal Version: 5.3
Component: Editor Keywords: has-screenshots needs-patch
Focuses: ui Cc:
PR Number:

Description

Noticed that a very recent CSS change in Gutenberg that was merged yesterday in core breaks the radio buttons used by plugins within the editor meta boxes area.

Specifically the newly added margin: -3px -4px; makes the radio buttons "blue dot" completely misplaced:

Screenshot:

http://cldup.com/QXxyfcuyrt.png

See https://github.com/WordPress/gutenberg/pull/18108/files#diff-0ad88efa3865f313f57c422957d02b2fR99-R101

Removing those negative margins fixes the issue. I'm not sure those margins are really necessary, as removing them doesn't seem to change anything else. Also, the related Gutenberg pull request https://github.com/WordPress/gutenberg/pull/18108 was meant to fix issues within the sidebar, so I'm not sure why it's targeting the meta boxes area.

Change History (9)

#1 @youknowriad
5 weeks ago

Good catch, just to clarify the fix, that part of the sidebar is a metabox area.

#2 @afercia
5 weeks ago

To quickly reproduce: use Advanced Custom Fields and add a group with a radio button (and also a checkbox to double check the related CSS):

With the new negative margins:

http://cldup.com/7qZ41ueSpq.png

Without:

http://cldup.com/D4gMrqOmGU.png

#3 @afercia
5 weeks ago

Thanks for the clarification @youknowriad. Didn't know plugins/themes can add their own stuff within the default sidebar.

[Edit] dumb moment, because I actually knew that :D

Last edited 5 weeks ago by afercia (previous) (diff)

This ticket was mentioned in Slack in #core-editor by mcsf. View the logs.


5 weeks ago

#5 @afercia
5 weeks ago

A fix was merged in the Gutenberg plugin, see https://github.com/WordPress/gutenberg/issues/18181 and https://github.com/WordPress/gutenberg/pull/18183

Just needs to be synced to core.

#6 @johnbillion
5 weeks ago

  • Owner set to youknowriad
  • Status changed from new to assigned

@youknowriad Is this something you can facilitate?

#7 @youknowriad
5 weeks ago

yes this is fixed in #48502 we need some eyes on the patch and commiters to land it for RC4

This ticket was mentioned in Slack in #core by david.baumwald. View the logs.


5 weeks ago

#9 @azaozz
4 weeks ago

  • Milestone 5.3 deleted
  • Resolution set to duplicate
  • Status changed from assigned to closed

Closing as duplicate of #48502 as mentioned above.

Note: See TracTickets for help on using tickets.