WordPress.org

Make WordPress Core

Opened 7 years ago

Closed 7 years ago

#4849 closed defect (bug) (fixed)

Drafts with no titles don't appear in post-new.php

Reported by: markel Owned by: markjaquith
Milestone: 2.3 Priority: normal
Severity: normal Version: 2.3
Component: Administration Keywords: has-patch
Focuses: Cc:

Description

If a user has one or more drafts that do not have titles attached to them, the header for the draft list appears:

"Your drafts:"

and then no links or any other pieces of text are visible in the list. The next characters are a space and a period.

Attachments (2)

4849.diff (493 bytes) - added by Nazgul 7 years ago.
post-new_viper.patch (516 bytes) - added by Viper007Bond 7 years ago.
Alternate suggestion to avoid multiple "Untitled" listings

Download all attachments as: .zip

Change History (6)

Nazgul7 years ago

comment:1 Nazgul7 years ago

  • Keywords has-patch added

Same goes for Pending review posts.

Added a patch which fixes this by showing Untitled instead.

Viper007Bond7 years ago

Alternate suggestion to avoid multiple "Untitled" listings

comment:2 JeremyVisser7 years ago

Confirmed on trunk.

However, on my WPMU 1.2.4 installation (apparently based on WP 2.2.2), it does exactly what Viper's patch does (the one I just tested with made it Post # 313), so presumably that functionality was lost sometime ago.

comment:3 westi7 years ago

  • Owner changed from anonymous to markjaquith

Assigned to markjaquith who raised a dupe at #4911

comment:4 markjaquith7 years ago

  • Resolution set to fixed
  • Status changed from new to closed

(In [6037]) Show "Post #N" for posts without a title in the nag. Props Viper007Bond. fixes #4849

Note: See TracTickets for help on using tickets.