WordPress.org

Make WordPress Core

Opened 2 years ago

Last modified 13 days ago

#48495 reopened defect (bug)

Update failed A Valid URL was not provided

Reported by: tlembke Owned by:
Milestone: Awaiting Review Priority: normal
Severity: normal Version: 5.2.4
Component: Upgrade/Install Keywords: reporter-feedback dev-feedback
Focuses: administration, coding-standards Cc:

Description

Received above error message when updating (or downloading) all plugins on all sites in my system
Error resolved when changed wp-admin/includes/file,.php line in line 989

$response = wp_safe_remote_get(
To
$response = wp_remote_get(

Appears to be a url validation error , even though plugins that failed included
https://downloads.wordpress.org/plugin/akismet.4.1.3.zip

WordPress 5.2.4
Running PHP version: 7.3.2 (on FreePSB)

Change History (7)

#1 @karlte
2 years ago

  • Resolution set to duplicate
  • Status changed from new to closed

Hi tlembke,

please see ticket #48509.

I found a working solution ... please verify.

#2 @desrosj
2 years ago

  • Resolution duplicate deleted
  • Status changed from closed to reopened

Reopening this because #48509 has not been confirmed to fix the issue.

@tlembke can you provide more detailed steps to reproduce the issue that you are seeing? What is your system's setup? How are you trying to update the plugins? Is the error only returned for some, or all?

#3 @sdachs
18 months ago

Hello,
We have the same problems and the solution works.

We have a few wordpress instances and always the same errors whether wordpress-update or plugin-install/update. We have to use a proxy for the internet connection. Without proxy (direct internet connection) the download works without problems.

After every coreupdate we have to edit the file.php and remove the "safe" in wp_safe_remote_get

#4 @sdachs
7 months ago

Hello,
Bug is still there.
Everytime we update WordPress, we need to manually edit the file.php.
Do you have a solution for us?

#5 @sdachs
4 weeks ago

  • Focuses accessibility coding-standards added
  • Keywords dev-feedback added

Hello,
Bug still there.
The reason is the function wp_http_validate_url in http.php.
There is a gethostbyname()-function which do not work behind a proxy, because the proxy does the dns-lookup.
If i add in /etc/hosts a entry like
---
198.143.164.250 downloads.wordpress.org
---
the update/installation works.
Could you fix this in a further version?

This ticket was mentioned in Slack in #accessibility by ryokuhi. View the logs.


13 days ago

#7 @ryokuhi
13 days ago

  • Focuses accessibility removed

Hello @sdachs, and thanks for keeping an eye on this issue.

We reviewed this ticket today during the accessibility team's bug-scrub. As far as we can see, it doesn't seem that this is an accessibility issue, that is, an issue that mainly affects people with disabilities. As such, I'm removing the accessibility focus from this ticket.

If you still think that this issue is related to accessibility, feel free to add the focus back!

Note: See TracTickets for help on using tickets.