WordPress.org

Make WordPress Core

Opened 8 months ago

Closed 3 months ago

Last modified 24 hours ago

#48532 closed defect (bug) (invalid)

Sometimes image at the top of a page is not showing up in the editor

Reported by: cube1us Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Editor Keywords: has-screenshots
Focuses: Cc:

Description

I have a number of pages that have a Title block, followed by an Image block. Fairly frequently, the image is not displayed in the editor. It seems to happen most often when there is a second image shortly after the first one, perhaps separated by a text block. The Editor does not even recognize that there is a block there. There is a lso a banner image (present in all of my pages)

Sample of a page where this happens:

https://www.computercollection.net/index.php/pdp8and12/

Screenshots of the above page in the editor and from the browser are attached. This is happening on quite a few pages.

Only plugins active: Envira Gallery Lite (this image on this page does NOT use it, but the page does use it further down), Folders, UpdarftPlus - Backup/Restore

Attachments (4)

20191107-Wordpress-editor-page-missing-first image.png (347.8 KB) - added by cube1us 8 months ago.
Screenshot showing no image, in the Editor
20191107-Wordpress-browser-page-missing-first image.png (506.0 KB) - added by cube1us 8 months ago.
Screenshot showing the image in browser
featured-image-sidebar.png (81.6 KB) - added by sabernhardt 3 months ago.
featured-image-sidebar-sample.png (19.1 KB) - added by sabernhardt 3 months ago.

Download all attachments as: .zip

Change History (12)

@cube1us
8 months ago

Screenshot showing no image, in the Editor

@cube1us
8 months ago

Screenshot showing the image in browser

#1 @sabernhardt
3 months ago

@cube1us Hi and thanks for the report!

That extra image should be the post's Featured Image, which is not located in a block. You can find, set or remove the featured image in the editor's sidebar (click the gear-shaped icon to expand the Settings panel/sidebar).

The Twenty Sixteen theme displays the Featured Image after the post title and before the post content (blocks).

#2 @cube1us
3 months ago

@sabernhardt A couple of things which make me believe your comment is not a solution:

1) This is on a page, not a post
2) The image is the Header Image for the page, not a featured image.

So I believe this should still be an open issue.

#3 @sabernhardt
3 months ago

@cube1us Yes, it may be on pages, but your site has support for adding post-thumbnails (featured images) to pages. That support is likely included in a plugin, or maybe in your (child) theme.

This is the example page's featured image markup:

		<div class="post-thumbnail">
			<img width="480" height="640" src="https://www.computercollection.net/wp-content/uploads/2019/06/pdp12-8.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" srcset="https://www.computercollection.net/wp-content/uploads/2019/06/pdp12-8.jpg 480w, https://www.computercollection.net/wp-content/uploads/2019/06/pdp12-8-225x300.jpg 225w" sizes="(max-width: 709px) 85vw, (max-width: 909px) 67vw, (max-width: 984px) 60vw, (max-width: 1362px) 62vw, 840px" />	</div><!-- .post-thumbnail -->

The theme's header image is inserted on all pages and posts, linking to the home page, and the featured images are unique to any pages/posts that have one assigned.

If you don't see the "Featured image" section in the sidebar under "Document" settings, you may need to:

  1. Click on the three-dot icon to expand that menu,
  2. Select "Options" at the bottom and
  3. Make sure "Featured image" is checked.

#4 @cube1us
3 months ago

I'm not interested in a "work around". I am not interested in "help" or guidance. I reported this so someone might fix the bug. The site WORKS FINE when viewed as such.

FYI, my child theme is trivial, involving just a footer and a very simple css for some fonts. The header image exists in both the child theme and the parent. When I created the child theme in June 2019, it did not properly inherit the header image.

#5 @knutsp
3 months ago

  • Resolution set to invalid
  • Status changed from new to closed
  • Version 5.2.4 deleted

This is not a bug.

As @sabernhardt points out, the html source clearly shows that the first image inside the "entry-content", the part of the page controlled by the editor content area, is "2019/06/pdp8l.jpg", while "2019/06/pdp12-8.jpg" is the featured image, and above that we have the "2019/06/cropped-IMG_4853-1.jpg" which is provided by the actual or general page template.

#6 @cube1us
3 months ago

I see. FYI, I DID NOT CREATE THAT AS A FEATURED IMAGE. The editor seems to have done that ON ITS OWN. I originally put in place in the page editor just like all of my other images. I didn't even know that such a thing as a "featured image" existed.

I have fixed it. But color me annoyed.

#7 @cube1us
3 months ago

I found a total of three pages like that - which explains the apparent hit-or-miss flavor of the issue.

As I mentioned, I was not even aware that such a thing as a featured image existed - I am pretty sure I did not explicit set any of these that way. None of my other pages had them, just the three I found tonight.

#8 @desrosj
24 hours ago

  • Milestone Awaiting Review deleted
Note: See TracTickets for help on using tickets.