WordPress.org

Make WordPress Core

Opened 2 months ago

Last modified 2 months ago

#48540 new defect (bug)

wp-pass.php and wp-register.php should be deleted on update

Reported by: wojsmol Owned by:
Milestone: Awaiting Review Priority: normal
Severity: normal Version: 5.2.4
Component: Upgrade/Install Keywords:
Focuses: Cc:
PR Number:

Description

Hi

IMHO wp-pass.php and wp-register.php should be deleted on update. I find this issue when checking core checksums after big WP update.

Change History (1)

#1 @SergeyBiryukov
2 months ago

  • Component changed from General to Upgrade/Install

Hi there, welcome to WordPress Trac! Thanks for the ticket.

For some context, these files were removed for new installs, but kept on existing installs to prevent possible breakage in case of being used directly:

To proceed with the removal of these files from existing installs, the plugin directory should be scanned to find out if they are still used by any plugins, and a dev note should be written on http://make.wordpress.org/core/.

Note: See TracTickets for help on using tickets.