WordPress.org

Make WordPress Core

Opened 2 months ago

Last modified 2 months ago

#48611 new defect (bug)

WordPress theme wanting to update but to older version 4.9.7

Reported by: kmjames Owned by:
Milestone: Awaiting Review Priority: normal
Severity: normal Version: 5.2.4
Component: Upgrade/Install Keywords: reporter-feedback close
Focuses: Cc:
PR Number:

Description

On my updates page WordPress is strangely suggesting that I "update" to an older wordpress version. How can I remedy this?

It is currently version 5.4.2 but it wants to "update" to 4.9.7.

Please help!

Thank you

Kate

Attachments (1)

MSwebsite.jpg (172.8 KB) - added by kmjames 2 months ago.
screenshot

Download all attachments as: .zip

Change History (3)

@kmjames
2 months ago

screenshot

#1 follow-up: @garrett-eclipse
2 months ago

  • Keywords reporter-feedback close added

Hello @kmjames

With recent API changes to the WordPress update server the highest version that your server will support will be prompted for you. The reason you aren't seeing WordPress 5.3 as an available update is most likely because your server PHP is not supported.

Please see this article for helpful information to upgrade your server PHP;
https://wordpress.org/support/update-php/
*In many cases you'll just have to contact your hosting company to conduct the upgrade.

Once on a supported PHP version the latestt WordPress will become available for updating.

Leaving this open for now in case PHP version isn't actually the issue.

#2 in reply to: ↑ 1 @SergeyBiryukov
2 months ago

  • Component changed from General to Upgrade/Install

Replying to garrett-eclipse:

With recent API changes to the WordPress update server the highest version that your server will support will be prompted for you. The reason you aren't seeing WordPress 5.3 as an available update is most likely because your server PHP is not supported.

I doubt PHP version is the issue here. The requirements for WordPress 5.2 and 5.3 are the same, so if the site currently runs on WordPress 5.2.4, it should be able to update to 5.3.

Additionally, if PHP version was the issue, then the suggested version for updating would be 5.1.x, which is the latest version that runs on older PHP (< 5.6.20).

Looking at the page source, it appears that the WP version was modified to a0a16caeef95c61d122831efd5fed58c, which likely confuses the update API. Since it's an issue with how this particular site is configured, rather than a bug in core, I'd suggest trying the support forums for further troubleshooting: https://wordpress.org/support/forums.

Note: See TracTickets for help on using tickets.