WordPress.org

Make WordPress Core

Opened 7 months ago

Closed 4 months ago

#48611 closed defect (bug) (invalid)

WordPress theme wanting to update but to older version 4.9.7

Reported by: kmjames Owned by:
Milestone: Priority: normal
Severity: normal Version: 5.2.4
Component: Upgrade/Install Keywords:
Focuses: Cc:

Description

On my updates page WordPress is strangely suggesting that I "update" to an older wordpress version. How can I remedy this?

It is currently version 5.4.2 but it wants to "update" to 4.9.7.

Please help!

Thank you

Kate

Attachments (1)

MSwebsite.jpg (172.8 KB) - added by kmjames 7 months ago.
screenshot

Download all attachments as: .zip

Change History (6)

@kmjames
7 months ago

screenshot

#1 follow-up: @garrett-eclipse
7 months ago

  • Keywords reporter-feedback close added

Hello @kmjames

With recent API changes to the WordPress update server the highest version that your server will support will be prompted for you. The reason you aren't seeing WordPress 5.3 as an available update is most likely because your server PHP is not supported.

Please see this article for helpful information to upgrade your server PHP;
https://wordpress.org/support/update-php/
*In many cases you'll just have to contact your hosting company to conduct the upgrade.

Once on a supported PHP version the latestt WordPress will become available for updating.

Leaving this open for now in case PHP version isn't actually the issue.

#2 in reply to: ↑ 1 @SergeyBiryukov
7 months ago

  • Component changed from General to Upgrade/Install

Replying to garrett-eclipse:

With recent API changes to the WordPress update server the highest version that your server will support will be prompted for you. The reason you aren't seeing WordPress 5.3 as an available update is most likely because your server PHP is not supported.

I doubt PHP version is the issue here. The requirements for WordPress 5.2 and 5.3 are the same, so if the site currently runs on WordPress 5.2.4, it should be able to update to 5.3.

Additionally, if PHP version was the issue, then the suggested version for updating would be 5.1.x, which is the latest version that runs on older PHP (< 5.6.20).

Looking at the page source, it appears that the WP version was modified to a0a16caeef95c61d122831efd5fed58c, which likely confuses the update API. Since it's an issue with how this particular site is configured, rather than a bug in core, I'd suggest trying the support forums for further troubleshooting: https://wordpress.org/support/forums.

#3 @dd32
4 months ago

The WordPress update check is supposed to use a "clean" $wp_version to avoid plugins that mess with the WordPress version number from causing problems like this.

It looks like the site in question is now running WordPress 5.3.2, but still has a security/privacy plugin messing with the version data.

@kmjames Is this still happening for you? Does it persist after deactivating your Security/Privacy plugins (temporarily, to find out if they're the cause) and visiting Dashboard -> Updates and clicking Check Now?

IMHO: This is probably caused by a bad plugin, and there's not a lot WordPress can do to prevent things like that happening

#4 @kmjames
4 months ago

Hi thanks you all who contributed to my query, however this is now three months old and in the meantime I've managed to resolve it.

I do realise plugins can cause these types of errors, but in the end I think I went in via my hosting back end to update that way and it then worked, not that I can remember each detail now!

Thanks again :)

#5 @garrett-eclipse
4 months ago

  • Keywords reporter-feedback close removed
  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed

Thanks for the follow-up @kmjames I'm going to close this ticket out as you've been able to resolve your issue and it appeared to be more likely related to a plugin or other customization which modified the $wp_version.

Note: See TracTickets for help on using tickets.