WordPress.org

Make WordPress Core

Opened 13 years ago

Closed 13 years ago

#4862 closed defect (bug) (fixed)

"Older posts" link not working for archive pages

Reported by: hughbiquitous Owned by:
Milestone: 2.3 Priority: normal
Severity: normal Version: 2.3
Component: General Keywords:
Focuses: Cc:

Description

In my archive pages, the posts_nav_link is (correctly) producing a link like this:

http://example.com/2007/03/page/2/

...but when I click it, it takes me to:

http://example.com/2007/03/

My code is checked out from trunk at version 5966 from SVN.

I've verified this for monthly archives, category archives, and author archives. However, paging on the home page (ie., http://example.com/page/2/ and subsequent pages) works just fine.

I've also tried disabling all plugins and switching to the default theme, and the issue is still observed.

Change History (2)

#1 @westi
13 years ago

Probably related to #4773

#2 @markjaquith
13 years ago

  • Resolution set to fixed
  • Status changed from new to closed

(In [5974]) Fix paging and preview links for canonical stuff. see #4773. fixes #4862

Note: See TracTickets for help on using tickets.