WordPress.org

Make WordPress Core

Opened 23 months ago

Closed 23 months ago

Last modified 23 months ago

#48639 closed defect (bug) (invalid)

syntax error on line 1059 functions.php file

Reported by: tevaw19108 Owned by:
Milestone: Priority: normal
Severity: major Version: 5.3
Component: Site Health Keywords:
Focuses: coding-standards Cc:

Description

i want to report syntax error on line 1059 in file ../wp-includes/functions.php

please confirm and update.

php version 5.5

Change History (2)

#1 @pbiron
23 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed

Thanx for the ticket (and welcome to Trac!).

WordPress 5.3 introduced the spread operator to a lot of core functions/methods.

The minimum version of PHP supported is 5.6.20 (starting with WordPress 5.2).

So this is not really a syntax error. You will need to update your version of PHP to be able to use WordPress 5.3.

Last edited 23 months ago by SergeyBiryukov (previous) (diff)

#2 @SergeyBiryukov
23 months ago

Just noting that I could not reproduce the syntax error here.

In my testing with an older PHP version, WordPress displays a proper error message, as expected:

Your server is running PHP version 5.5.38 but WordPress 5.3 requires at least 5.6.20.

Related: #48059

Note: See TracTickets for help on using tickets.