WordPress.org

Make WordPress Core

Opened 4 weeks ago

Closed 3 days ago

#48643 closed defect (bug) (fixed)

Twenty Twenty: the menu on a mobile device becomes responsive after tapping a few times and switching pages

Reported by: smatt33 Owned by:
Milestone: 5.4 Priority: normal
Severity: normal Version: 5.3
Component: Bundled Theme Keywords: 2nd-opinion
Focuses: ui, javascript Cc:
PR Number:

Description

Hello!
I have found a problem in the theme Twenty Twenty. I can replicate this both on my website and on the demo of the theme in the WordPress gallery, both in Chrome for Android and for the desktop (using the developer tools and simulating a mobile device).

Fundamentally, if you tap multiple times the mobile menu, then tap a page, then go back to the home and keep tapping multiple times on the menu button, at a certain point the menu will become unresponsive and the menu will not show up anymore.

The Javascript console shows the following error:

https://i.imgur.com/LSZHovC.png

"Uncaught TypeError: Cannot read property 'classList' of null

at index.js?ver=1.0:83
at index.js?ver=1.0:85"

The culprit seems to be line 83:

" document.body.classList.add( 'touch-enabled' );"

Unfortunately, I don't know how to fix this, so my knowledge stops here. However, I hope this can be fixed soon, as it makes Twenty Twenty unreliable.

Change History (5)

#1 @ianbelanger
4 weeks ago

Related to and possibly a duplicate of #48601

#2 @ianbelanger
3 weeks ago

  • Milestone changed from Awaiting Review to 5.3.1

This ticket was mentioned in Slack in #core by audrasjb. View the logs.


7 days ago

#4 @audrasjb
7 days ago

  • Keywords 2nd-opinion added
  • Milestone changed from 5.3.1 to 5.4

Hi,
@ianbelanger as #48601 was closed as fixed, is this one also covered by the changes?
By the way, as this ticket still needs a patch, let's move it to milestone 5.4

#5 @ianbelanger
3 days ago

  • Resolution set to fixed
  • Status changed from new to closed

This issue appears to have been fixed by #48601, so I am closing this ticket.

Note: See TracTickets for help on using tickets.