Make WordPress Core

Opened 5 years ago

Closed 4 years ago

Last modified 3 years ago

#48659 closed defect (bug) (invalid)

Gallery Block Does Not Include Alt Tag Content

Reported by: jackstouffer's profile jackstouffer Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Editor Keywords:
Focuses: accessibility Cc:

Description

Observed Behavior:

When creating a image gallery with the built-in block and using images from the media library, the gallery does not include the alt tag content that's set from the media library in the actual image tag on the page.

Expected Behavior:

Each image tag in the gallery should include the alt tag contents.

Change History (6)

#1 @audrasjb
5 years ago

  • Component changed from General to Editor
  • Focuses accessibility added

#2 @audrasjb
5 years ago

  • Version 5.3 deleted

#3 @afercia
5 years ago

  • Keywords reporter-feedback added

@jackstouffer thanks for your report and welcome to Trac! I wasn't able to reproduce: for me, the gallery images have the alt attribute populated with the value from the Media Library.

When you have a chance, please describe the steps you followed to reproduce the issue.

Does it still happen with all plugins disabled and a default theme (for example Twenty Twenty or Twenty Nineteen) activated?

This ticket was mentioned in Slack in #accessibility by afercia. View the logs.


4 years ago

#5 @afercia
4 years ago

  • Keywords reporter-feedback removed
  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed

Tested again during today's accessibility bug-scrub and couldn't reproduce. Closing this ticket. Can always be reopened if something was missed.

#6 @maxakohler
3 years ago

I ran into a similar issue today (on WordPress 5.8.2), and I think it might be what happened to OP. Steps to reproduce:

  1. Create a new post
  2. Create a new gallery block, and upload a bunch of images to it.
  3. Save the post
  4. Then go into the media library and add alt texts to the images you just uploaded.

You might expect those alt texts to automatically appear in the post we created earlier, but they don't. Instead you need to:

  1. Edit the post
  2. Click on each image in the gallery, and re-add it from the media library.
  3. Save the post

Now the alt texts appear on the front end as expected.

I'm not sure if this even qualifies as a bug, I just thought I'd add my experience.

Note: See TracTickets for help on using tickets.